Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libcups2-2.2.4-1.mga6 RPM for armv5tl

From Mageia 6 for armv5tl / media / core / updates

Name: libcups2 Distribution: Mageia
Version: 2.2.4 Vendor: Mageia.Org
Release: 1.mga6 Build date: Sun Jul 30 04:55:40 2017
Group: System/Libraries Build host: armlet5.mageia.org
Size: 701272 Source RPM: cups-2.2.4-1.mga6.src.rpm
Packager: luigiwalser <luigiwalser>
Url: http://www.cups.org
Summary: CUPS printing system - CUPS library
The CUPS printing system provides a portable printing layer for
UNIX(TM) operating systems. This package contains the CUPS API library
which contains common functions used by both the CUPS daemon and all
CUPS frontends (lpr-cups, xpp, qtcups, kups, ...).

This package you need for both CUPS clients and servers. It is also
needed by Samba.

Provides

Requires

License

LGPLv2

Changelog

* Sun Jul 30 2017 luigiwalser <luigiwalser> 2.2.4-1.mga6
  + Revision: 1132652
  - update to 2.2.4 (mga#21168)
  - sync patches with fedora
  - adding group wheel to SystemGroup (rhbz#1405669)
* Fri May 26 2017 neoclust <neoclust> 2.2.3-2.mga6
  + Revision: 1104819
  - Rebuild to see if it help to fix a crash
* Wed Mar 29 2017 luigiwalser <luigiwalser> 2.2.3-1.mga6
  + Revision: 1095169
  - 2.2.3
* Mon Mar 27 2017 luigiwalser <luigiwalser> 2.2.2-1.mga6
  + Revision: 1094913
  - 2.2.2
  - sync patch changes with fedora
* Thu Dec 01 2016 tv <tv> 2.2.1-1.mga6
  + Revision: 1071394
  - new release
  - Unable to print from Windows (7) on a Cups-Server with german umlauts in the filename (rhbz#1386751)
  - (cups-usb-quirks) usb printer doesn't print (usblp0: USB Bidirectional printer dev) (#873123)
* Fri Sep 30 2016 tv <tv> 2.2.0-3.mga6
  + Revision: 1057856
  - fixing looping in partial failing service (bug #1366775)
* Wed Sep 21 2016 pterjan <pterjan> 2.2.0-2.mga6
  + Revision: 1054997
  - Fix manpage extension in alternatives, this should be made more robust
* Thu Sep 15 2016 tv <tv> 2.2.0-1.mga6
  + Revision: 1053128
  - new version
* Fri Jun 17 2016 tv <tv> 2.1.4-1.mga6
  + Revision: 1021975
  - new release
* Tue Jun 07 2016 tv <tv> 2.1.3-3.mga6
  + Revision: 1020634
  - adjust BRs for latest systemd
* Sun Apr 10 2016 blino <blino> 2.1.3-2.mga6
  + Revision: 1000167
  - drop poppler requires, pdftops was required by filters which have been split out in 1.6
* Mon Feb 08 2016 tv <tv> 2.1.3-1.mga6
  + Revision: 950444
  - 2.1.3
* Mon Jan 11 2016 luigiwalser <luigiwalser> 2.1.2-2.mga6
  + Revision: 921799
  - rebuild for gnutls
* Mon Dec 07 2015 tv <tv> 2.1.2-1.mga6
  + Revision: 908714
  - new release
  - new release
* Tue Dec 01 2015 tv <tv> 2.1.1-1.mga6
  + Revision: 907521
  - adjust file list
  - drop merged patch
  - drop merged patch
  - new release
  - notice that this package is synced with FC
* Thu Oct 29 2015 doktor5000 <doktor5000> 2.1.0-3.mga6
  + Revision: 896420
  - added upstream fix for cups STR#4725
    o fixes issues with non-world-readable PPD files for ipp:// printers
  
    + akien <akien>
      - Repackage mistakenly removed translation po files (mga#16321)
* Sun Sep 13 2015 blino <blino> 2.1.0-2.mga6
  + Revision: 878875
  - allow to skip python-cups buildrequire for bootstrap
  - package cups icons (buildrequire desktop-common-data to get them installed)
* Wed Sep 02 2015 tv <tv> 2.1.0-1.mga6
  + Revision: 872266
  - new release
  - new release
* Sat Aug 29 2015 tv <tv> 2.0.4-2.mga6
  + Revision: 870782
  - ship macros.cups from FC (needed for new cups-filters)
* Sat Aug 29 2015 tv <tv> 2.0.4-1.mga6
  + Revision: 870765
  - new release
* Tue Aug 25 2015 pterjan <pterjan> 2.0.3-7.mga6
  + Revision: 869216
  - Rebuild with gcc 5
* Fri Aug 21 2015 tmb <tmb> 2.0.3-6.mga6
  + Revision: 867560
  - rebuild for new gcc
* Sun Jul 26 2015 tv <tv> 2.0.3-5.mga6
  + Revision: 857751
  - drop old conflicts on cupsddk
* Sat Jul 25 2015 tv <tv> 2.0.3-4.mga6
  + Revision: 857624
  - remove obsolete BRs
  - fixed CREDITS.txt character encoding
  - fix "WARNING: unrecognized options: --with-pdftops"
  - reorder some requires (reduce diff with FC)
  - BR python-cups in order to get postscriptdriver tags
  - stop advertizing cups-1.1 vs cups-1.4
  - kill poll_ppd_base (do not build for 2 years)
  - further simplify
  - simplify
* Fri Jul 03 2015 tv <tv> 2.0.3-3.mga6
  + Revision: 849668
  - fix upgrade
* Fri Jul 03 2015 tv <tv> 2.0.3-2.mga6
  + Revision: 849635
  - fix slow resume of jobs after restart (STR #4646)
  - fix redirection from CGI scripts (rhbz#1232030, STR #4538)
  - also trigger cups-lp.conf
  - move doc in %_datadir/cups/www (reduce diff with FC)
  - add configure options from FC
  - try running as group 'lp' instead of 'sys'
  - reduce diff with FC (s/buildroot/RPM_BUILD_ROOT/, bug ref, ..)
  - compress PDD
  - sync alternatives with FC (less diff)
  - kill old mdv build workaround
  - kill alternatives for accept/reject/disable (mga#11008)
* Sat Jun 20 2015 tv <tv> 2.0.3-1.mga6
  + Revision: 835803
  - 2.0.3
  - remove upstreamed patches
* Wed Jun 10 2015 luigiwalser <luigiwalser> 2.0.2-5.mga5
  + Revision: 822968
  - add upstream patches to fix two security issues fixed in 2.0.3:
    - STR#4609 (CVE-2015-1158 and CVE-2015-1159)
    - STR#4602
  - update cups-lspp.patch (from fedora)
* Fri May 01 2015 tv <tv> 2.0.2-4.mga5
  + Revision: 820955
  - bump release for core/release
* Tue Mar 17 2015 tv <tv> 2.0.2-3.mga5
  + Revision: 818707
  - Avoid busy loop in cupsd when connection is closed after request
    sent (rhbz#1179596).
* Fri Feb 20 2015 tv <tv> 2.0.2-2.mga5
  + Revision: 816080
  - Fixed multilib.patch to check for gnutls instead of openssl (from FC)
* Wed Feb 11 2015 tv <tv> 2.0.2-1.mga5
  + Revision: 814731
  - new release
* Sun Feb 01 2015 tv <tv> 2.0.1-3.mga5
  + Revision: 812964
  - fix systemd notify support (rhbz#1184453)
* Mon Jan 05 2015 shlomif <shlomif> 2.0.1-2.mga5
  + Revision: 808632
  - Don't Add BrowseAddress which is invalid cups conf syntax (MGA #14952).
    Thanks to Richard Houser, who is my apprentice.
* Sun Nov 16 2014 tv <tv> 2.0.1-1.mga5
  + Revision: 797556
  - 2.0.1
  - sync with FC:
    o Re-introduce SSLOptions configuration directive, disable SSL3 by
      default (STR #4476).
    o Enable SSL again via GnuTLS (bug #1161235).
    o Removed openssl requirements from spec file as it is no longer
      supported upstream (see bug #1161235).
    o New systemd journal fields CUPS_DEST and CUPS_PRINTER, as well as
      accurate code location fields.
* Thu Nov 13 2014 tv <tv> 2.0.0-2.mga5
  + Revision: 796857
  - rebuild for core/release
* Thu Oct 23 2014 tv <tv> 2.0.0-1.mga5
  + Revision: 792587
  - new release
  - drop merged patch
* Wed Oct 15 2014 umeabot <umeabot> 1.7.5-9.mga5
  + Revision: 741526
  - Second Mageia 5 Mass Rebuild
* Fri Oct 03 2014 luigiwalser <luigiwalser> 1.7.5-8.mga5
  + Revision: 736484
  - sync patches with fedora (update str#4461 patch from upstream and add str#4475)
* Thu Sep 18 2014 umeabot <umeabot> 1.7.5-7.mga5
  + Revision: 693708
  - Rebuild to fix library dependencies
* Tue Sep 16 2014 umeabot <umeabot> 1.7.5-6.mga5
  + Revision: 678618
  - Mageia 5 Mass Rebuild
  
    + tv <tv>
      - s/uggests:/Recommends:/
* Tue Sep 09 2014 luigiwalser <luigiwalser> 1.7.5-5.mga5
  + Revision: 673880
  - no longer requires net-tools (only uses commands from hostname package)
* Tue Sep 09 2014 luigiwalser <luigiwalser> 1.7.5-4.mga5
  + Revision: 673844
  - add requires on hostname now that it is in a different package
* Thu Sep 04 2014 joequant <joequant> 1.7.5-3.mga5
  + Revision: 671740
  - update to new systemd
* Sat Aug 30 2014 tv <tv> 1.7.5-2.mga5
  + Revision: 669522
  - sync patches with FC:
    o Use upstream patch for STR #4461.
    o Upstream patch for STR #4396, pre-requisite for STR #2913 patch.
    o Upstream patch for STR #2913 to limit Get-Jobs replies to 500 jobs
      (bug #421671).
    o Fix conf/log file reading for authenticated users (STR #4461).
* Fri Aug 01 2014 tv <tv> 1.7.5-1.mga5
  + Revision: 658892
  - new release
* Thu Jul 31 2014 tv <tv> 1.7.4-4.mga5
  + Revision: 658391
  - we use FC patches

Files

/usr/lib/libcups.so.2
/usr/lib/libcupscgi.so.1
/usr/lib/libcupsimage.so.2
/usr/lib/libcupsmime.so.1
/usr/lib/libcupsppdc.so.1


Generated by rpm2html 1.8.1

Fabrice Bellet, Sun May 10 01:41:58 2020