Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

python-interlude-1.3.1-lp151.2.2 RPM for noarch

From OpenSuSE Leap 15.1 for noarch

Name: python-interlude Distribution: openSUSE Leap 15.1
Version: 1.3.1 Vendor: openSUSE
Release: lp151.2.2 Build date: Mon Dec 10 22:14:43 2018
Group: Development/Languages/Python Build host: lamb71
Size: 10627 Source RPM: python-interlude-1.3.1-lp151.2.2.src.rpm
Packager: https://bugs.opensuse.org
Url: http://github.com/collective/interlude
Summary: Interlude for Doctests provides an Interactive Console
Provides an interactive shell aka console inside your doctest case.

The console looks exact like in a doctest-case and you can copy and paste
code from the shell into your doctest. It feels as you are in the test case
itself. Its not pdb, it's a python shell.

In your doctest you can invoke the shell at any point by calling::

    >>> interact( locals() )

To make your testrunner interlude aware following is needed:

Provides

Requires

License

LGPL-3.0+

Changelog

* Wed May 06 2015 benoit.monin@gmx.fr
  - update to version 1.3.1:
    * refactoring introduced bug: classic prompt use_ipython=False
      fails if IPython available
  - additional changes from version 1.3:
    * needs IPython 1.1.0 or better. Skipped support for older
      versions.
    * added extra require, so when ipython is wanted just depend in
      buildout, pip-requirements, setup, (name it) on
      interlude[ipython]
    * start IPython shell with a custom doctest prompt, thus it is
      easier to copy-paste from the shell to the doctest
* Sun Dec 08 2013 p.drouand@gmail.com
  - Update to version 1.2
    + make the ipython support work with newer ipython versions
* Thu Oct 24 2013 speilicke@suse.com
  - Require python-setuptools instead of distribute (upstreams merged)
* Wed Mar 14 2012 saschpe@suse.de
  - Use license mentioned in README.rst
* Mon Mar 12 2012 saschpe@suse.de
  - Initial version

Files

/usr/lib/python2.7/site-packages/interlude
/usr/lib/python2.7/site-packages/interlude-1.3.1-py2.7.egg-info
/usr/lib/python2.7/site-packages/interlude-1.3.1-py2.7.egg-info/PKG-INFO
/usr/lib/python2.7/site-packages/interlude-1.3.1-py2.7.egg-info/SOURCES.txt
/usr/lib/python2.7/site-packages/interlude-1.3.1-py2.7.egg-info/dependency_links.txt
/usr/lib/python2.7/site-packages/interlude-1.3.1-py2.7.egg-info/namespace_packages.txt
/usr/lib/python2.7/site-packages/interlude-1.3.1-py2.7.egg-info/requires.txt
/usr/lib/python2.7/site-packages/interlude-1.3.1-py2.7.egg-info/top_level.txt
/usr/lib/python2.7/site-packages/interlude-1.3.1-py2.7.egg-info/zip-safe
/usr/lib/python2.7/site-packages/interlude/__init__.py
/usr/lib/python2.7/site-packages/interlude/__init__.pyc
/usr/share/doc/packages/python-interlude
/usr/share/doc/packages/python-interlude/CHANGELOG.rst
/usr/share/doc/packages/python-interlude/README.rst


Generated by rpm2html 1.8.1

Fabrice Bellet, Sun Nov 10 11:00:55 2019