Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libIL1-1.7.8-10.2 RPM for aarch64

From OpenSuSE Ports Tumbleweed for aarch64

Name: libIL1 Distribution: openSUSE Tumbleweed
Version: 1.7.8 Vendor: openSUSE
Release: 10.2 Build date: Mon Nov 18 23:13:22 2019
Group: System/Libraries Build host: armbuild25
Size: 872675 Source RPM: libdevil-1.7.8-10.2.src.rpm
Packager: http://bugs.opensuse.org
Url: http://openil.sourceforge.net/
Summary: A cross-platform image library
Developer's Image Library (DevIL) is a programmer's library to
develop applications with image loading capabilities. Control of
images is left to the developer, so unnecessary conversions, etc. are
not performed. DevIL can load, save, convert, manipulate, filter and
display a wide variety of image formats.

Currently, DevIL can load .bmp, .cut, .dds, .doom, .gif, .ico, .jpg,
.lbm, .mdl, .mng, .pal, .pbm, .pcd, .pcx, .pgm, .pic, .png, .ppm,
.psd, .psp, .raw, .sgi, .tga and .tif .hdr files.
Formats supported for saving include .bmp, .dds, .h, .jpg, .pal,
.pbm, .pcx, .hdr, .pgm,.png, .ppm, .raw, .sgi, .tga and .tif.

DevIL currently supports the following APIs for display: OpenGL,
SDL and Allegro.

Provides

Requires

License

LGPL-2.1-only

Changelog

* Wed Aug 21 2019 Jan Engelhardt <jengelh@inai.de>
  - Remove bias and marketing wording from descriptions.
* Wed Aug 21 2019 mvetter@suse.com
  - bsc#1144245: Remove JPEG2000 support due to dropping dependency
    on libjasper
  - Run spec-cleaner
* Sat May 12 2018 antoine.belvire@opensuse.org
  - Fix %install_info_delete usage:
    * It has to be performed in %preun, not %postun.
    * See https://en.opensuse.org/openSUSE:Packaging_Conventions_RPM_Macros#.25install_info_delete.
* Sat Apr 07 2018 wbauer@tmo.at
  - Add jp2-remove-use-of-uchar-define.patch to fix build with newer
    jasPer
* Mon May 29 2017 dimstar@opensuse.org
  - Drop lcms-devel BuildRequires and pass --disable-lcms to
    configure: lcms upstream explicitly recommends no longer to use
    this outdated version of the library (DevIL 1.8.0 seems to gain
    lcms2 support).
* Fri Jun 26 2015 antoine.belvire@laposte.net
  - Fix compilation with GCC 5: add DevIL-1.7.8-gcc5.patch.
* Wed Oct 02 2013 lnussel@suse.de
  - make sure to not use il_wdp.c
* Sat Sep 07 2013 tchvatal@suse.com
  - Kill the mandriva code as they are not using it anyway.
  - Add missing deps to build all features possible
  - Move the ilur binary to separate tools package as it is GPL-3.0+
    licensed.
* Mon Aug 26 2013 tchvatal@suse.com
  - Fix wrong require on -devel package.
* Fri Aug 23 2013 mhrusecky@suse.cz
  - Renamed spec and main package to be consistent

Files

/usr/lib64/libIL.so.1
/usr/lib64/libIL.so.1.1.0
/usr/lib64/libILU.so.1
/usr/lib64/libILU.so.1.1.0
/usr/lib64/libILUT.so.1
/usr/lib64/libILUT.so.1.1.0
/usr/share/doc/packages/libIL1
/usr/share/doc/packages/libIL1/AUTHORS
/usr/share/doc/packages/libIL1/CREDITS
/usr/share/doc/packages/libIL1/NEWS
/usr/share/doc/packages/libIL1/README
/usr/share/doc/packages/libIL1/README.unix
/usr/share/doc/packages/libIL1/TODO
/usr/share/info/DevIL_manual.info.gz
/usr/share/licenses/libIL1
/usr/share/licenses/libIL1/COPYING


Generated by rpm2html 1.8.1

Fabrice Bellet, Wed Feb 12 00:15:37 2020