Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

NetworkManager-openconnect-1.2.6-1.1 RPM for riscv64

From OpenSuSE Ports Tumbleweed for riscv64

Name: NetworkManager-openconnect Distribution: openSUSE Tumbleweed
Version: 1.2.6 Vendor: openSUSE
Release: 1.1 Build date: Tue Aug 13 13:29:55 2019
Group: Productivity/Networking/System Build host: cloud133
Size: 87147 Source RPM: NetworkManager-openconnect-1.2.6-1.1.src.rpm
Packager: http://bugs.opensuse.org
Url: http://www.gnome.org/projects/NetworkManager
Summary: NetworkManager VPN support for OpenConnect
NetworkManager-openconnect provides VPN support to NetworkManager for
OpenConnect, an implementation of the Cisco AnyConnect VPN system.

Provides

Requires

License

GPL-2.0-or-later AND LGPL-2.1-only

Changelog

* Wed Aug 07 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 1.2.6:
    + libnm-glib compatibility (NetworkManager < 1.0) is disabled by
      default. It can be enabled by passing --with-libnm-glib to
      configure script. Nobody should need it by now. Users that
      still use this are encouraged to let us know before the
      libnm-glib support is removed for good.
    + Allow key files for TPM v2.0 to be configured.
    + Add support for PAN GlobalProtect and native Pulse Secure
      protocol.
    + Discourage users from accepting bad server certificates.
    + Add persistent support (beware
      https://bugzilla.gnome.org/794190 though).
  - Add pkgconfig(gcr-3) BuildRequires: New dependency.
  - Use modern macros.
* Sat Apr 14 2018 bjorn.lie@gmail.com
  - Following changes in NetworkManager: pass without-libnm-glib to
    configure, no longer build deprecated libnm-glib support.
  - Following the above changes: Drop no longer needed
    pkgconfig(NetworkManager), pkgconfig(libnm-glib),
    pkgconfig(libnm-glib-vpn) and pkgconfig(libnm-util)
    BuildRequires.
  - Drop no longer needed export CFLAGS="%%{optflags}
    - Wno-deprecated-declarations".
  - Drop unnneeded NetworkManager-gnome Requires from gnome
    sub-package, it is not longer of use for us.
* Wed Feb 28 2018 dimstar@opensuse.org
  - Modernize spec-file by calling spec-cleaner
* Tue Dec 06 2016 dimstar@opensuse.org
  - Update to version 1.2.4:
    + Split libnm-vpn-plugin-openconnect.so into a GTK-free core
      plugin usable by nmcli and a UI plugin for nm-applet and GNOME
      components.
    + Support NM_VPN_LOG_LEVEL environment variable to control debug
      logging from NetworkManager.
    + Support Juniper Network Connect / Junos Pulse Secure VPN.
    + Add Yubikey OATH support.
    + Added support for automatic login when all needed data is
      known.
    + Fixed support for IPv6-only VPNs.
    + Updated translations.
* Sat May 14 2016 zaitor@opensuse.org
  - Update to version 1.2.2:
    + Use a proper name for the AppStream metadata.
    + Updated translations.
* Mon May 02 2016 dimstar@opensuse.org
  - Update to version 1.2.0:
    + build: don't include the full path to a plugin by default.
    + Updated translations.
* Wed Apr 06 2016 dimstar@opensuse.org
  - Update to version 1.1.93 (1.2-rc1):
    + No changes.
  - Changes from version 1.1.92:
    + plugin: avoid calling GetAll on service object.
    + Updated translations.
* Tue Mar 01 2016 dimstar@opensuse.org
  - Update to version 1.1.91:
    + service: drop off the bus if the peer vanishes or we're
      unneeded.
    + Updated translations.
* Thu Jan 21 2016 dimstar@opensuse.org
  - Update to version 1.1.90:
    + Ported to libnm, libnma and GDBus.
    + Support multiple concurrent VPN connections.
    + Updated translations.
  - Add pkgconfig(libnm) BuildRequires: new dependency.
* Sun Nov 22 2015 zaitor@opensuse.org
  - Update to version 1.0.8:
    + Updated translations.
* Wed May 06 2015 dimstar@opensuse.org
  - Update to version 1.0.2:
    + Updated translations.
* Tue Mar 17 2015 dimstar@opensuse.org
  - Replace openconnect-devel BuildRequires with
    pkgconfig(openconnect), matching what configure checks for.
* Tue Jan 27 2015 dimstar@opensuse.org
  - Update to version 1.0.0:
    + Dropped support for libopenconnect.so.1.
    + Added support for libopenconnect.so.4.
    + Added support HMAC-based One Time Password (HOTP).
    + Updated translations.
  - Drop NetworkManager-openconnect-7.0.patch: fixed upstream.
* Mon Dec 08 2014 dimstar@opensuse.org
  - Add NetworkManager-openconnect-7.0.patch: Fix build with
    OpenConnect 7.0. Patch taken from git, commit 58944a3.

Files

/etc/dbus-1/system.d/nm-openconnect-service.conf
/usr/lib/NetworkManager
/usr/lib/NetworkManager/VPN
/usr/lib/NetworkManager/VPN/nm-openconnect-service.name
/usr/lib/nm-openconnect-service
/usr/lib/nm-openconnect-service-openconnect-helper
/usr/lib64/NetworkManager/libnm-vpn-plugin-openconnect.so
/usr/share/doc/packages/NetworkManager-openconnect
/usr/share/doc/packages/NetworkManager-openconnect/AUTHORS
/usr/share/doc/packages/NetworkManager-openconnect/ChangeLog
/usr/share/doc/packages/NetworkManager-openconnect/NEWS
/usr/share/licenses/NetworkManager-openconnect
/usr/share/licenses/NetworkManager-openconnect/COPYING


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Oct 22 00:35:49 2019