Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

geronimo-interceptor-3_0-api-1.2-36.4 RPM for noarch

From OpenSuSE Tumbleweed for noarch

Name: geronimo-interceptor-3_0-api Distribution: openSUSE Tumbleweed
Version: 1.2 Vendor: openSUSE
Release: 36.4 Build date: Wed Aug 26 01:11:30 2020
Group: Development/Languages/Java Build host: sheep88
Size: 17853 Source RPM: geronimo-specs-1.2-36.4.src.rpm
Packager: https://bugs.opensuse.org
Url: http://geronimo.apache.org
Summary: Geronimo J2EE server J2EE specifications
Geronimo is Apache's ASF-licenced J2EE server project. These are the
J2EE-Specifications Note: You should use the subpackages for the
Specifications that you actually need.	The ones installed by the main
package are deprecated and will disapear in future releases.

Provides

Requires

License

Apache-2.0

Changelog

* Mon Jan 27 2020 Fridrich Strba <fstrba@suse.com>
  - On supported platforms, avoid building with OpenJ9, in order to
    prevent build cycles.
* Tue Dec 10 2019 Fridrich Strba <fstrba@suse.com>
  - Set version for the specs comming from tag 1_1_1 in order to
    avoid unexpanded version macros in pom files.
* Mon Apr 15 2019 Fridrich Strba <fstrba@suse.com>
  - Removed patches:
    * geronimo-specs-1.2-pom_xml.patch
    * geronimo-specs-corba-2.3-pom_xml.patch
    * geronimo-specs-j2ee-1.4-pom_xml.patch
    * geronimo-specs-j2ee-connector-1.5-pom_xml.patch
    * geronimo-specs-jta-1.0.1B-pom_xml.patch
    * geronimo-specs-servlet-2.4-pom_xml.patch
      + Not needed since we are not building with maven and some
      of the modifications are possible using the
      javapackages-local macros.
  - Remove all reference to parent pom, since we are not building
    with maven, and don't package the parent pom in this build.
  - Stop using alternatives to handle different versions of provides.
  - Avoid multiplication of jar symlinks
* Fri Apr 12 2019 Julio Gonzalez Gil <jgonzalez@suse.com>
  - Obsoletes, conflicts and provides must use only %%{version} as the
    the release is managed automatically by OBS and not needed  (bsc#1132514)
* Tue Mar 19 2019 Fridrich Strba <fstrba@suse.com>
  - Let each package obsolete and conflict with the
    %%{name}-poms < %%{version}-%%{release} in order to make upgrades
    smooth
* Thu Dec 13 2018 Fridrich Strba <fstrba@suse.com>
  - Add alias javax.jms:jms to geronimo-jms-1_1-api
* Wed Nov 21 2018 Fridrich Strba <fstrba@suse.com>
  - Add aliases org.eclipse.jetty.orbit:javax.transaction and
    javax.transaction:jta to geronimo-jta-1_1-api
* Mon Nov 12 2018 Fridrich Strba <fstrba@suse.com>
  - Add alias javax.persistence:persistence-api to
    geronimo-jpa-3.0-api subpackage
* Mon Nov 12 2018 Fridrich Strba <fstrba@suse.com>
  - Package the pom files together with their corresponding jars,
    since packaging poms separately makes no sense at all
  - Rename geronimo-specs-poms package to geronimo-specs-pom, since
    it now contains only the parent pom.
* Fri Nov 09 2018 Fridrich Strba <fstrba@suse.com>
  - Add two aliases to the maven artifact in
    geronimo-annotation-1_0-api sub-package
* Mon Jul 16 2018 fstrba@suse.com
  - BuildConflict with java-devel >= 11, since the build uses tools
    and APIs removed in jdk11
* Thu May 17 2018 fstrba@suse.com
  - Build with source and target 8 to prepare for a possible removal
    of 1.6 compatibility
* Fri Sep 08 2017 fstrba@suse.com
  - Specify java source and target version to 1.6 in order to allow
    build with jdk9
  - Modified source:
    * geronimo-specs.build.xml
    - specify encoding UTF-8, since the files use UTF-8 characters
* Fri May 19 2017 tchvatal@suse.com
  - Remove javadoc to cut build time in half
* Fri May 19 2017 tchvatal@suse.com
  - Fix building with new javapackages-tools
  - Remove unused conditionals
* Wed Mar 18 2015 tchvatal@suse.com
  - Fix build with new javapackages-tools
* Tue Jul 29 2014 tchvatal@suse.com
  - Do not mess with defattr as it is pointless.
* Fri Jul 25 2014 tchvatal@suse.com
  - Try to use the update-alternatives properly.
* Mon Sep 09 2013 tchvatal@suse.com
  - Move from jpackage-utils to javapackage-tools
* Tue Sep 03 2013 mvyskocil@suse.com
  - use add_maven_depmap from javapackages-tools
* Mon Dec 17 2012 mvyskocil@suse.com
  - drop useless excalibur-avalon from build requires
* Mon Sep 19 2011 mvyskocil@suse.cz
  - fix a typo in alternatives --install call causing a build failure
* Wed May 06 2009 mvyskocil@suse.cz
  - Update to 1.2
    * bugfix release and update release
    * JPA support.
    * CA - Certificate Authority capabilities, you can now issue certificates in
      reply to CSRs. See http://cwiki.apache.org/GMOxDOC12/certification-authority.html
  - synchronized specfile with jpackage 5.0
    * mavenized
    * obsoleted geronimo-specs-j2ee-management-pom.patch,
      geronimo-specs-pom_xml.patch, geronimo-spec-javamail-sun-security.patch
    * do not use triggers
    * use alternatives system
  - used one build.xml for all packages ==> shorter %%build section
  - fdupes used on javadoc
  - new packages
    * geronimo-ws-metadata
    * geronimo-stax-1_0-api
    * geronimo-servlet-2_5
    * geronimo-jta-1_1-api
    * geronimo-jsp-2_1-api
    * geronimo-jpa-3_0-api
    * geronimo-javamail-1_4-api
    * geronimo-j2ee-management-1_1
    * geronimo-jacc-1_1-api
    * geronimo-javaee-deployment
    * geronimo-interceptor-3_0-api
    * geronimo-el-1_0-api
    * geronimo-ejb-3_0-api
    * geronimo-annotation-1_0-api
    * geronimo-jaf-1_1-api
    * geronimo-specs-javadoc
  - undot.py to remove dots from package names
  - remove %%{release} from Requires
* Mon Dec 01 2008 mvyskocil@suse.cz
  - added a Conflicts to gnu-jaf to geronimo-jav-1_0_2-api
* Tue Aug 26 2008 anosek@suse.cz
  - fixed path to LICENSE.txt files in spec
* Mon Aug 25 2008 mvyskocil@suse.cz
  - target=1.5 source=1.5
  - removed a gcj support
  - fixed some rpmlint warnings
* Mon Apr 21 2008 ro@suse.de
  - changed requires of main package to use underscores as well
* Thu Apr 17 2008 mvyskocil@suse.cz
  - Dots in names was replaced by underscore
  - Added a PreReq on coreutils
  - Removed of BuildRoot removal in %install phase
* Mon Apr 07 2008 mvyskocil@suse.cz
  - First release in Suse (JPP 1.7) version 1.1
    - build dependency for log4j update [bnc#355798]
    - added a build support using ant
    - FIXME: the corba-3.0 package is not currently included

Files

/usr/share/java/geronimo-interceptor-3.0-api.jar
/usr/share/licenses/geronimo-interceptor-3_0-api
/usr/share/licenses/geronimo-interceptor-3_0-api/LICENSE.txt
/usr/share/maven-metadata/geronimo-specs-interceptor-3.0-api.xml
/usr/share/maven-poms/JPP-geronimo-interceptor-3.0-api.pom


Generated by rpm2html 1.8.1

Fabrice Bellet, Wed Oct 28 23:40:07 2020