Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

nginx-module-acme-0.4.2-1.1 RPM for x86_64

From OpenSuSE Tumbleweed for x86_64

Name: nginx-module-acme Distribution: openSUSE Tumbleweed
Version: 0.4.2 Vendor: openSUSE
Release: 1.1 Build date: Tue Nov 10 09:25:43 2026
Group: Unspecified Build host: reproducible
Size: 1225853 Source RPM: nginx-module-acme-0.4.2-1.1.src.rpm
Packager: https://bugs.opensuse.org
Url: https://github.com/nginx/nginx-acme
Summary: NGINX module for automatic certificate management (ACMEv2)
Nginx-acme is an NGINX module implementation of the automatic
certificate management (ACMEv2) protocol.

The module implements the following specifications:

* RFC8555 (Automatic Certificate Management Environment) with
  limitations: Only HTTP-01 challenge type is supported
* RFC8737 (ACME TLS Application-Layer Protocol Negotiation (ALPN)
  Challenge Extension)
* RFC8738 (ACME IP Identifier Validation Extension)

Provides

Requires

License

Apache-2.0

Changelog

* Tue Nov 10 2026 Mia Herkt <mia@0x0.st>
  - Update to version 0.4.2
    Bugfixes:
    * State files are now created with restricted permissions.
      Previously, only the state directory was protected.
    * ACME server responses with escaped URLs failed to parse.
    * Some non-compliant ACME server responses with missing fields
      failed to parse.
    * Orders for pre-authorized identifiers that omit the
      authorizations field failed to parse.
    * The actual ACME server error was not logged correctly
      if the response had no Replay-Nonce header.
    * Order finalization errors were not logged correctly.
  - Add keyring and use source_validator in localonly mode
* Fri May 01 2026 Mia Herkt <mia@0x0.st>
  - Update to version 0.4.1
    Bugfixes:
    * Possible crash during name resolution (via ngx v0.5.1).
* Mon Apr 20 2026 Mia Herkt <mia@0x0.st>
  - Update to version 0.4.0
    Changes:
    * Subject Common Name is no longer included in CSRs, as it is
      optional, cannot accommodate long domain names and can be
      rejected by some ACME issuers. This may result in issuing
      certificates with empty Subject Common Name. Such certificates
      are valid and should be accepted by any user agents.
      The common_name_in_csr directive allows restoring the previous
      behavior.
    * Renewal time for short-lived (less than 10 days) certificates
      is adjusted to the half of the certificate lifetime.
    * Some user-facing log messages (info, notices, warnings and
      errors) were modified.
    Features:
    * ACME Renewal Information checking is now supported and always
      enabled with compatible ACME CAs.
    Bugfixes:
    * Default acme_shared_zone size was insufficient on systems
      with 64k page size.
    * Log messages were not emitted on an expected log level.
    * Server certificate names were not verified when connecting
      to an issuer specified with IP address.
    * Server connection could fail when either IPv6 or IPv4 network
      is unreachable.
    * tls-alpn-01 challenge could generate an invalid certificate
      for domain names longer than 64 characters.
* Tue Feb 17 2026 Mia Herkt <mia@0x0.st>
  - Initial package, version 0.3.1

Files

/usr/lib64/nginx/modules/ngx_http_acme_module.so
/usr/share/doc/packages/nginx-module-acme
/usr/share/doc/packages/nginx-module-acme/CHANGELOG.md
/usr/share/doc/packages/nginx-module-acme/CODE_OF_CONDUCT.md
/usr/share/doc/packages/nginx-module-acme/CONTRIBUTING.md
/usr/share/doc/packages/nginx-module-acme/README.md
/usr/share/doc/packages/nginx-module-acme/SECURITY.md
/usr/share/doc/packages/nginx-module-acme/SUPPORT.md
/usr/share/licenses/nginx-module-acme
/usr/share/licenses/nginx-module-acme/LICENSE


Generated by rpm2html 1.8.1

Fabrice Bellet, Thu Nov 12 01:39:22 2026