Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

koan-2.8.2-lp152.5.3 RPM for noarch

From OpenSuSE Leap 15.2 for noarch

Name: koan Distribution: openSUSE Leap 15.2
Version: 2.8.2 Vendor: openSUSE
Release: lp152.5.3 Build date: Sun Mar 1 13:54:34 2020
Group: Applications/System Build host: lamb24
Size: 300712 Source RPM: cobbler-2.8.2-lp152.5.3.src.rpm
Packager: https://bugs.opensuse.org
Url: http://www.cobblerd.org/
Summary: Helper tool that performs cobbler orders on remote machines
Koan stands for kickstart-over-a-network and allows for both
network installation of new virtualized guests and reinstallation
of an existing system.  For use with a boot-server configured with Cobbler

Provides

Requires

License

GPL-2.0+

Changelog

* Thu Apr 26 2018 pablo.suarezhernandez@suse.com
  - Escape shell parameters provided by the user for the
    reposync action (CVE-2017-1000469) (bsc#1074594)
  - Added:
    * escape-shell-parameters-provided-by-user-on-reposync.patch
* Mon Mar 05 2018 adam.majer@suse.de
  - Use cdrtools starting with SLE-15 and Leap-15 again.
    (bnc#1081739)
* Mon Nov 27 2017 pablo.suarezhernandez@suse.com
  - Cleanup of the spec file.
* Mon Nov 27 2017 jloeser@suse.com
  - fix creation of manpages:
      option '--release ""' resulted in empty man pages
  - added patch:
    * fix-manpage-creation.patch
* Wed Nov 08 2017 aavindraa@gmail.com
  - Update to latest stable version of cobbler (2.8.2)
    * many changes since 2.6.6. see: https://cobbler.github.io/posts/
  - rebase patches
    * koan_old_cobbler_compat.diff
    * disable_not_relevant_checks_bnc_828453.patch
    * update-outdated-apache-config-bsc956264.patch
      + potentionally fixed in 3d4db162c7b7c0fe7de00c30fcb81798b7db5039
  - remove fix-cobbler-loaders-server-bsc980577.patch
    * fixed in 77328c0b05d37878f13704efa31e4daa162fda12
  - remove vendor-files.tar.bz2
    * use built in manpage instead of vendored one
    * add cobbler_firewall_settings to package root
  - use py macros to do installation
* Thu Oct 05 2017 mihai.dinca@suse.com
  - fix script endpoint security bug CVE-2016-9605 (bsc#1030582)
    Add:
    * fix-script-endpoint-security-bug-1030582.patch
* Wed Oct 04 2017 mihai.dinca@suse.com
  - fix setup.py to identify SUSE OS correctly bsc#1046679
    Added:
    * fix-os-release.patch
* Fri Jul 28 2017 trenn@suse.de
  - Recommend fence-agents for broader power switch support
* Wed May 18 2016 pablo.suarezhernandez@suse.com
  - Update cobbler loaders server hostname bsc#980577
    Added:
    * fix-cobbler-loaders-server-bsc980577.patch
* Tue May 03 2016 mdinca@suse.de
  - Update outdated apache config bsc#956264
    * update-outdated-apache-config-bsc956264.patch
* Wed Mar 09 2016 bwiedemann@suse.com
  - Replace builddate with changelog date to fix build-compare (bsc#969538)
* Thu Jan 15 2015 fcastelli@suse.com
  - Added 'fix_test_create_systems.diff': fixes the "create_systens" unit test
* Tue Jan 13 2015 fcastelli@suse.com
  - Fix runtime dependency: ensure the yaml module is available.
* Tue Jan 13 2015 fcastelli@suse.com
  - Install the right cobblerd.service file
* Mon Jan 12 2015 fcastelli@suse.com
  - Do not ship cobbler_web.conf inside of the cobbler package, get rid
    of part of our patches to setup.py,
* Fri Dec 19 2014 fcastelli@suse.com
  - Added new patch required to fix the broken unit tests:
    * fix-broken-tests.diff
* Thu Dec 18 2014 fcastelli@suse.com
  - Removed another no longer needed patch:
    * fix-textmode-for-SUSE.dif
* Thu Dec 18 2014 fcastelli@suse.com
  - Update to latest stable version of cobbler (2.6.6)
  - Removed no longer needed patches
    * bnc_877009.patch
    * cobbler-2.4.2-Fix-koan-s-get_insert_script.patch
    * fix-broken-tests.diff
    * fix-initscript.diff
    * suse_config.diff
  - Fixed old patches to apply against the new code:
    * catch_cheetah_exception.patch
    * grubby-compat.diff
    * setup_py.diff
* Mon Dec 15 2014 fcastelli@suse.com
  - Fix the broken unit tests
* Thu Dec 11 2014 mseidl@suse.de
  - Created sub package for unit tests
* Tue Dec 09 2014 mc@suse.de
  - use fdupes only on SUSE
* Mon Dec 08 2014 dmacvicar@suse.de
  - Fix for re-installation of machines on SLE with static
    network configuration (bnc#883487)
  - Added patches:
    * cobbler-2.4.2-Fix-koan-s-get_insert_script.patch
    * cobbler-2.4.2-reprovision-rhel-on-suse-bnc883487.patch
* Thu Nov 27 2014 mc@suse.de
  - fix port guessing in koan (bsc#855389)
    * fix-koan-port-guessing.dif
  - add "copy-default" option to grubby-compat (bsc#855389)
  - handle elilo in SUSE (bsc#855389)
* Wed Nov 26 2014 mc@suse.de
  - fix wrong option "text" in SUSE environment (bsc#901058)
    * fix-textmode-for-SUSE.dif

Files

/usr/bin/cobbler-register
/usr/bin/koan
/usr/bin/ovz-install
/usr/lib/python2.7/site-packages/koan
/usr/lib/python2.7/site-packages/koan/__init__.py
/usr/lib/python2.7/site-packages/koan/__init__.pyc
/usr/lib/python2.7/site-packages/koan/__init__.pyo
/usr/lib/python2.7/site-packages/koan/app.py
/usr/lib/python2.7/site-packages/koan/app.pyc
/usr/lib/python2.7/site-packages/koan/app.pyo
/usr/lib/python2.7/site-packages/koan/configurator.py
/usr/lib/python2.7/site-packages/koan/configurator.pyc
/usr/lib/python2.7/site-packages/koan/configurator.pyo
/usr/lib/python2.7/site-packages/koan/imagecreate.py
/usr/lib/python2.7/site-packages/koan/imagecreate.pyc
/usr/lib/python2.7/site-packages/koan/imagecreate.pyo
/usr/lib/python2.7/site-packages/koan/openvzcreate.py
/usr/lib/python2.7/site-packages/koan/openvzcreate.pyc
/usr/lib/python2.7/site-packages/koan/openvzcreate.pyo
/usr/lib/python2.7/site-packages/koan/qcreate.py
/usr/lib/python2.7/site-packages/koan/qcreate.pyc
/usr/lib/python2.7/site-packages/koan/qcreate.pyo
/usr/lib/python2.7/site-packages/koan/register.py
/usr/lib/python2.7/site-packages/koan/register.pyc
/usr/lib/python2.7/site-packages/koan/register.pyo
/usr/lib/python2.7/site-packages/koan/utils.py
/usr/lib/python2.7/site-packages/koan/utils.pyc
/usr/lib/python2.7/site-packages/koan/utils.pyo
/usr/lib/python2.7/site-packages/koan/virtinstall.py
/usr/lib/python2.7/site-packages/koan/virtinstall.pyc
/usr/lib/python2.7/site-packages/koan/virtinstall.pyo
/usr/lib/python2.7/site-packages/koan/vmwcreate.py
/usr/lib/python2.7/site-packages/koan/vmwcreate.pyc
/usr/lib/python2.7/site-packages/koan/vmwcreate.pyo
/usr/lib/python2.7/site-packages/koan/xencreate.py
/usr/lib/python2.7/site-packages/koan/xencreate.pyc
/usr/lib/python2.7/site-packages/koan/xencreate.pyo
/usr/sbin/grubby-compat
/usr/share/doc/packages/koan
/usr/share/doc/packages/koan/AUTHORS
/usr/share/doc/packages/koan/COPYING
/usr/share/man/man1/cobbler-register.1.gz
/usr/share/man/man1/koan.1.gz
/var/lib/koan
/var/lib/koan/config
/var/log/koan
/var/spool/koan


Generated by rpm2html 1.8.1

Fabrice Bellet, Thu Jun 9 12:41:39 2022