Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

nvmetcli-0.7-lp152.1.1 RPM for noarch

From OpenSuSE Leap 15.2 for noarch

Name: nvmetcli Distribution: openSUSE Leap 15.2
Version: 0.7 Vendor: openSUSE
Release: lp152.1.1 Build date: Sun Apr 12 20:44:36 2020
Group: System/Management Build host: cloud105
Size: 118853 Source RPM: nvmetcli-0.7-lp152.1.1.src.rpm
Packager: https://bugs.opensuse.org
Url: http://git.infradead.org/users/hch/nvmetcli.git
Summary: Command line interface for the kernel NVMe nvmet
This package contains the command line interface to the NVMe over
Fabrics target in the Linux kernel. It allows configuring the NVMe
target interactively as well as saving / restoring the configuration
to / from a json file.

Provides

Requires

License

Apache-2.0

Changelog

* Fri Mar 27 2020 hare@suse.de
  - Update to version v0.7:
    * bump version to v0.7
    * nvmetcli: ANA configuration support
    * nvmetcli: simplify the enabled logic
    * nvmetcli: pep8 fixes
    * nvmetcli: support inline_data_size port parameter
    * Revert "nvmetcli: expose nvmet port status and state"
    * Support python3 dictionary access.
    * nvmetcli: expose nvmet port status and state
  - Remove patches merged with upstream:
    * nvmetcli-make-dict-access-python-version-independant.patch
    * nvmetcli-ANA-configuration-support.patch
  - 'clear' command doesn't handle ANA groups correctly (bsc#1167644)
    adding patch
    - 0001-nvmetcli-don-t-remove-ANA-Group-1-on-clear.patch
* Fri Mar 29 2019 hare@suse.de
  - Add ANA support (bsc#1130981)
    * nvmetcli-ANA-configuration-support.patch
* Mon Apr 16 2018 lduncan@suse.com
  - Stop using singlespec, since we only need a
    python3 version of this package, and we do not
    want it named "python3-nvmetcli" (bsc#1082208).
    Also, use the "python-six" module to make
    dictionary iteration work for Python 2 and 3,
    adding patch:
    * nvmetcli-make-dict-access-python-version-independant.patch
* Fri Apr 13 2018 lduncan@suse.com
  - Support python3 by using the python-six module,
    and convert dictionary access to use 'six' routines,
    so we can work on python 2 or python 3 (bsc#1082208)
* Sun Apr 08 2018 lduncan@suse.com
  - Convert to Python3-only siglespec (bsc#1082208)
    * Update the SPEC file, using singlespec format, but
      telling the macros to ignore Python2
    * Tell the scripts to use Python3 instead of python,
      adding patch:
    - nvmetcli-update-python-to-python3.patch
* Tue Jan 23 2018 jthumshirn@suse.com
  - Update to version v0.6: (FATE#322737)
    - 0001-nvmetcli-remove-status-method-for-the-uiportnode.patch
    * nvmetcli: remove status method for the UIPortNode
    * nvmetcli: expose ls to dump UI configuration
    * nvmetcli: decorate namespace, subsystem and port UI
    * nvmetcli: port decoration coloring only if its enabled
    * bump version to v0.6
* Fri Dec 01 2017 jthumshirn@suse.com
  - Don't display bogus 'disabled' status for ports (bsc#1070533)
    + 0001-nvmetcli-remove-status-method-for-the-uiportnode.patch
* Fri Aug 11 2017 jthumshirn@suse.com
  - Update to version v0.5: (FATE#322737)
    - 0001-nvmetcli-add-support-for-NS-UUIDs.patch
    * nvmetcli: add support for NS UUIDs
    * nvmetcli: allow setting of serial number number
    * nvmetcli: allow setting of the subsystem version
    * add a make clean pass to bump-ver.sh
    * bump version to v0.5
* Fri Jun 16 2017 jthumshirn@suse.com
  - Add possibiliy to configure Namespace UUIDs (bsc#1038235)
    + 0001-nvmetcli-add-support-for-NS-UUIDs.patch
* Tue May 23 2017 jthumshirn@suse.com
  - Change dependency from python-configshell to python-configshell-fb (bsc#1040212)
* Mon May 08 2017 jthumshirn@suse.com
  - Update to version v0.4: (bsc#1034105)
    * add example configuration files
    * update .gitignore for the auto-generated manpage formats
    * add a bump-ver.sh script to automate cutting releases
    * bump version to v0.3
    * nvmetcli: fix Port and Host operations in shell
    * nvmetcli: fix Referral operation in shell
    * nvmetcli: Install nvmetcli in /usr/sbin with setup.py
    * nvmetcli: create json file's dir first if it doesn't exist
    * Add fc transport support to nvmetcli
    * bump version to v0.4
* Sat Feb 11 2017 jengelh@inai.de
  - expand nvmet
* Wed Oct 12 2016 jthumshirn@suse.com
  - Initial import for SUSE (FATE#321732)

Files

/etc/nvmet
/usr/lib/python3.6/site-packages
/usr/lib/python3.6/site-packages/nvmet
/usr/lib/python3.6/site-packages/nvmet/__init__.py
/usr/lib/python3.6/site-packages/nvmet/__pycache__
/usr/lib/python3.6/site-packages/nvmet/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/nvmet/__pycache__/nvme.cpython-36.pyc
/usr/lib/python3.6/site-packages/nvmet/__pycache__/test_nvmet.cpython-36.pyc
/usr/lib/python3.6/site-packages/nvmet/nvme.py
/usr/lib/python3.6/site-packages/nvmet/test_nvmet.py
/usr/lib/python3.6/site-packages/nvmetcli-0.7-py3.6.egg-info
/usr/lib/python3.6/site-packages/nvmetcli-0.7-py3.6.egg-info/PKG-INFO
/usr/lib/python3.6/site-packages/nvmetcli-0.7-py3.6.egg-info/SOURCES.txt
/usr/lib/python3.6/site-packages/nvmetcli-0.7-py3.6.egg-info/dependency_links.txt
/usr/lib/python3.6/site-packages/nvmetcli-0.7-py3.6.egg-info/top_level.txt
/usr/lib/systemd/system/nvmet.service
/usr/sbin/nvmetcli
/usr/sbin/rcnvmet
/usr/share/doc/packages/nvmetcli
/usr/share/doc/packages/nvmetcli/COPYING
/usr/share/doc/packages/nvmetcli/README


Generated by rpm2html 1.8.1

Fabrice Bellet, Mon May 9 12:54:53 2022