Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

speech-dispatcher-0.8.8-3.6.3 RPM for s390x

From OpenSuSE Leap 15.3 for s390x

Name: speech-dispatcher Distribution: SUSE Linux Enterprise 15
Version: 0.8.8 Vendor: SUSE LLC <https://www.suse.com/>
Release: 3.6.3 Build date: Wed Apr 17 16:06:15 2019
Group: System/Daemons Build host: s390zp37
Size: 1126001 Source RPM: speech-dispatcher-0.8.8-3.6.3.src.rpm
Packager: https://www.suse.com/
Url: https://devel.freebsoft.org/speechd
Summary: Device independent layer for speech synthesis
The goal of Speech Dispatcher project is to provide a high-level device
independent layer for speech synthesis through a simple, stable and
well documented interface.

What is a very high level GUI library to graphics, Speech Dispatcher is
to speech synthesis. The application neither needs to talk to the
devices directly nor to handle concurrent access, sound output and other
tricky aspects of the speech subsystem.

Provides

Requires

License

GPL-2.0+

Changelog

* Wed Mar 27 2019 dimstar@opensuse.org
  - Revert setting includedir explicitly: upstream had this fixed in
    2015 in the build system directly (bsc#1129586 is thus no longer
    applicable since speech-dispatcher 0.8.4).
* Tue Mar 19 2019 ro@suse.de
  - set includedir to fix the entries in the pkg-config file
    (bsc#1129586)
* Wed Feb 07 2018 aloisio@gmx.com
  - Update to version 0.8.8
    * Add German translation, thanks to Chris Leick for the patch
    * Fix some spelling mistakes, thanks to Paul Gevers for the patch
    * Some slight code improvements
* Wed Jan 03 2018 dimstar@opensuse.org
  - Add baselibs.conf: create libspeechd2-32bit, required by
    libQt5TextToSpeech5-32bit.
* Thu Nov 30 2017 dimstar@opensuse.org
  - Drop py_requires: this is a static python2-dependency on a
    python3 package.
* Fri Sep 15 2017 mgorse@suse.com
  - Update to version 0.8.7:
    + Further fixes to spd-conf, which should now work properly.
    + Split the espeak-ng driver code into its own source file.
    + Add a work-around to the espeak-ng driver to account for spaces
      in voice names which recently appeared in espeak-ng git master.
      This will properly be fixed in 0.9.
    + Voice names are not forced to lower case, due to espeak-ng
      git master now having multi-case voice names.
    + Fix stripped audio output from the flite module.
    + Further code and build improvements.
  - Changes from version 0.8.6:
    + Various internal code improvements.
    + Fix more compiler warnings.
    + Python bug fixes with thanks to Sebastian Humenda.
  - Changes from version 0.8.5:
    + Use GLib main loop for the main server thread
    + Implement a shutdown timer in the server
    + Add support for espeak-ng.
    + Document an ibmtts configuration option
    + Removal of configuration options in the code that were not
      actually being used.
    + Added a command-line argument to allow for custom modules
      location.
  - Add ANNOUNCE; remove ChangeLog (no longer shipped)
* Sat Jul 01 2017 dimstar@opensuse.org
  - Drop %py_requires from python3-speechd: this is a python2
    dependency on a python3 package.
* Tue Oct 04 2016 ro@suse.de
  - speech-dispatcher.logrotate: move options to local scope
    to not affect logrotate configuration for other services
    (bsc#1001618)
* Mon May 16 2016 mgorse@suse.com
  - Update to version 0.8.4:
    + Updated documentation for required dependencies and where to
      find them.
    + Removed unused code.
    + Fixed compiler and GLib warnings.
    + Cleanup header definitions and inclusions.
    + Enabled silent rules by default
    + Fix language identification references.
* Sun Jul 19 2015 opensuse.lietuviu.kalba@gmail.com
  - Update to version 0.8.3:
    * Add API methods to get language, rate, pitch, and volume.
    * A lot of code cleanup, and compatibility improvements.
    * Removed all references to GNOME Speech, since it has long since been
    deprecated.
    * Fix some inconsistancy in the SSIP API for voice type.
    * The SET VOICE SSIP command is now deprecated, and will be removed in 0.9.
    * The C library API now provides macro definitions for major, minor, and micro
    versions in libspeechd_versions.h.
    * The libsndfile library is now a mandetory dependency to improve the user
    experience around sound icons.
    * Fix a possible crash in the festival driver (drop bnc-831609-festival-crash.patch).
    * Add a configuration option to the espeak driver to show voice variants in the
    voice list. This will remain until a proper variants retrieval API is added
    for compatible synthesizers.
* Fri Mar 27 2015 benoit.monin@gmx.fr
  - cleanup spec file with spec-cleaner
  - update to version 0.8.2:
    * Add convenience methods to the libspeech API to free module
      list and voice data structures.
    * Add method to the libspeechd API to get the current output
      module, and update the documentation accordingly.
    * The API is now licensed under the GNU Lesser General Public
      License v2.1 or later.
    * The spdconf configuration utility is now translatable.
    * Fixed a bug where speech-dispatcher would fail to start if the
      user configuration directory existed but did not contain a
      config file.
    * Install the spdconf desktop file.
  - add rcspeech-dispatcherd symlink for service
* Sat Dec 20 2014 opensuse.lietuviu.kalba@gmail.com
  - Update to 0.8.1
    + User dictionaries support added to the IBMTTS driver
    + Added a pico configuration file for use with the generic driver
    + Better support for multi-arch enabled distros to facilitate the use of the
      i386 only IBMTTS driver being easily installable on an amd64 system
    + Bug fixes, and documentation cleanup
  - Don't remove configuration in /usr/share/speech-dispatcher/config,
    because it is used by its configuration program to create user
    specific settings, while duplicate of it in /etc is system-wide

Files

/etc/logrotate.d/speech-dispatcher
/etc/speech-dispatcher
/etc/speech-dispatcher/clients
/etc/speech-dispatcher/clients/emacs.conf
/etc/speech-dispatcher/modules
/etc/speech-dispatcher/modules/cicero.conf
/etc/speech-dispatcher/modules/dtk-generic.conf
/etc/speech-dispatcher/modules/epos-generic.conf
/etc/speech-dispatcher/modules/espeak-generic.conf
/etc/speech-dispatcher/modules/espeak-mbrola-generic.conf
/etc/speech-dispatcher/modules/espeak-ng.conf
/etc/speech-dispatcher/modules/festival.conf
/etc/speech-dispatcher/modules/llia_phon-generic.conf
/etc/speech-dispatcher/modules/pico-generic.conf
/etc/speech-dispatcher/modules/swift-generic.conf
/etc/speech-dispatcher/speechd.conf
/usr/bin/spd-say
/usr/bin/spdsend
/usr/bin/speech-dispatcher
/usr/lib/systemd/system/speech-dispatcherd.service
/usr/lib64/speech-dispatcher
/usr/lib64/speech-dispatcher-modules
/usr/lib64/speech-dispatcher-modules/sd_cicero
/usr/lib64/speech-dispatcher-modules/sd_dummy
/usr/lib64/speech-dispatcher-modules/sd_festival
/usr/lib64/speech-dispatcher-modules/sd_generic
/usr/lib64/speech-dispatcher/spd_alsa.so
/usr/lib64/speech-dispatcher/spd_libao.so
/usr/lib64/speech-dispatcher/spd_oss.so
/usr/lib64/speech-dispatcher/spd_pulse.so
/usr/sbin/rcspeech-dispatcherd
/usr/share/doc/packages/speech-dispatcher
/usr/share/doc/packages/speech-dispatcher/ANNOUNCE
/usr/share/doc/packages/speech-dispatcher/AUTHORS
/usr/share/doc/packages/speech-dispatcher/COPYING
/usr/share/doc/packages/speech-dispatcher/NEWS
/usr/share/doc/packages/speech-dispatcher/README
/usr/share/info/spd-say.info.gz
/usr/share/info/speech-dispatcher-cs.info.gz
/usr/share/info/speech-dispatcher.info.gz
/usr/share/info/ssip.info.gz
/usr/share/locale/cs/LC_MESSAGES/speech-dispatcher.mo
/usr/share/locale/de/LC_MESSAGES/speech-dispatcher.mo
/usr/share/locale/hu/LC_MESSAGES/speech-dispatcher.mo
/usr/share/sounds/speech-dispatcher
/usr/share/sounds/speech-dispatcher/dummy-message.wav
/usr/share/sounds/speech-dispatcher/test.wav
/var/log/speech-dispatcher


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Aug 9 16:16:26 2022