Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libQt6Gui6-6.2.2-150400.2.8 RPM for aarch64

From OpenSuSE Leap 15.4 for aarch64

Name: libQt6Gui6 Distribution: SUSE Linux Enterprise 15
Version: 6.2.2 Vendor: SUSE LLC <https://www.suse.com/>
Release: 150400.2.8 Build date: Sun May 8 10:02:30 2022
Group: Unspecified Build host: ibs-arm-6
Size: 11679968 Source RPM: qt6-base-6.2.2-150400.2.8.src.rpm
Packager: https://www.suse.com/
Url: https://www.qt.io
Summary: Qt 6 GUI related libraries
The Qt GUI module provides classes for windowing system integration,
event handling, OpenGL and OpenGL ES integration, 2D graphics, basic
imaging, fonts and text. These classes are used internally by Qt's
user interface code and can also be used directly, for instance, to
write applications using low-level OpenGL ES graphics APIs.

For application developers writing user interfaces, Qt provides
higher level APIs, like Qt Quick, which are much more suitable than
the enablers found in the Qt GUI module.

Provides

Requires

License

LGPL-2.1-with-Qt-Company-Qt-exception-1.1 OR LGPL-3.0-only

Changelog

* Mon Feb 28 2022 christophe@krop.fr
  - Add upstream change (boo#1196501, CVE-2022-25255):
    * qprocess6-2.diff
  - Install qt6-core-private-devel when installing qt6-core-devel
    (boo#1195368)
* Wed Dec 22 2021 alarrosa@suse.com
  - Increase the memory constraint to fix a oom failure
* Wed Dec 01 2021 christophe@krop.fr
  - Update to 6.2.2
    * https://www.qt.io/blog/qt-6.2.2-released
  - Make sure all dependencies are present when installing devel
    packages. Qt >= 6.2.2 is much less permissive.
  - Drop 0001-qscrollarea-performance-fix.patch. Merged upstream.
* Thu Nov 04 2021 jonaski@opensuse.org
  - Add patch for critical performance regression in qscrollarea
    * 0001-qscrollarea-performance-fix.patch
* Tue Oct 26 2021 christophe@krop.fr
  - Update to 6.2.1
    * https://www.qt.io/blog/qt-6.2.1-released
* Thu Sep 30 2021 christophe@krop.fr
  - Update to 6.2.0:
    * https://www.qt.io/blog/qt-6.2-lts-released
* Sat Sep 25 2021 christophe@krop.fr
  - Update to 6.2.0-rc2
* Thu Sep 16 2021 christophe@krop.fr
  - Update to 6.2.0-rc
* Thu Sep 09 2021 christophe@krop.fr
  - Update to 6.2.0-beta4
* Wed Sep 01 2021 christophe@krop.fr
  - Update to 6.1.3:
    * https://www.qt.io/blog/qt-6.1.3-released
* Fri Jul 02 2021 christophe@krop.fr
  - Update to 6.1.2. New bugfix release:
    * https://www.qt.io/blog/qt-6.1.2-released
* Tue Jun 08 2021 christophe@krop.fr
  - Update to 6.1.1:
    * https://www.qt.io/blog/qt-6.1.1-released
* Sat Jun 05 2021 christophe@krop.fr
  - Update the minimum disk size. Leap 15.3 needs more than 13G.
  - Also require at least 4 cores.
* Thu May 06 2021 christophe@krop.fr
  - Update to 6.1.0:
    * https://www.qt.io/blog/qt-6.1-released
* Fri Apr 23 2021 christophe@krop.fr
  - Update to 6.1.0-rc.
* Sat Apr 17 2021 christophe@krop.fr
  - Stop owning directories provided by the filesystem package (boo#1184786)
* Tue Apr 13 2021 christophe@krop.fr
  - Update to 6.1.0-beta3.
* Wed Mar 31 2021 christophe@krop.fr
  - Update to 6.0.3
    * https://www.qt.io/blog/qt-6.0.3-released
* Sat Mar 20 2021 christophe@krop.fr
  - Update to 6.1.0-beta2
  - Drop fix-fixqt4headers.patch. No longer needed.
* Fri Mar 05 2021 christophe@krop.fr
  - Update to 6.1.0-beta1
    https://www.qt.io/blog/qt-6.1-beta-released
* Fri Mar 05 2021 christophe@krop.fr
  - Update to 6.0.2:
    https://www.qt.io/blog/qt-6.0.2-released
* Wed Feb 03 2021 christophe@krop.fr
  - Update to 6.0.1
    https://www.qt.io/blog/qt-6.0.1-released
  - Drop patches:
    * 0001-Fix-QCache-Crash.patch
    * 0001-CMake-Fix-conditions-for-some-subarch-features.patch
    * 0001-CMake-strip-the-executable-bit-from-qt-cmake-private.patch
  - Enable ltcg where possible.
* Sat Jan 23 2021 w01dnick@gmail.com
  - Remove uikit qmake spec to avoid automatic dep on python2
* Wed Dec 16 2020 christophe@krop.fr
  - Use a different 'Name' when building the docs flavor.
* Fri Dec 11 2020 jonas@jkvinge.net
  - Add patch for critical bug: QCache related crashes.
    * 0001-Fix-QCache-Crash.patch
* Tue Dec 08 2020 christophe@krop.fr
  - Update to 6.0.0:
    * https://www.qt.io/blog/qt-6.0-released
* Mon Dec 07 2020 christophe@krop.fr
  - libQt6Core6 now owns most of runtime folders and
    qt6-base-common-devel owns development ones.
* Thu Dec 03 2020 christophe@krop.fr
  - Disable the reduce_relocations option. (boo#1175278, QTBUG-86173)
* Wed Dec 02 2020 christophe@krop.fr
  - Qt 6.0.0 RC2
* Wed Dec 02 2020 christophe@krop.fr
  - Add the missing openssl dependency for qt6-network-private-devel
* Mon Nov 30 2020 christophe@krop.fr
  - Add upstream patches:
    * 0001-CMake-strip-the-executable-bit-from-qt-cmake-private.patch
    * 0001-CMake-Fix-conditions-for-some-subarch-features.patch
* Wed Nov 25 2020 christophe@krop.fr
  - Update to 6.0.0~rc1
* Tue Nov 17 2020 christophe@krop.fr
  - Update to 6.0.0~beta5
  - Drop upstream patches:
    * 0001-CMake-Potentially-use-INSTALL_LIBDIR-in-qt6_extract_.patch
    * 0001-CMake-Allow-using-DESTDIR-when-installing-documentat.patch
    * 0001-CMake-Make-zstd-config-based-lookup-quiet.patch
* Tue Nov 10 2020 christophe@krop.fr
  - Update to 6.0.0~beta4
  - Replace patches:
    * 0001-CMake-Allow-using-DESTDIR-when-installing-documentat.patch
      (replaces 0001-cmake-Fix-doc-installation.patch)
    * 0001-CMake-Potentially-use-INSTALL_LIBDIR-in-qt6_extract_.patch
      (replaces 0001-cmake-Don-t-hardcode-the-library-directory-name.patch)
  - Add upstream patch:
    * 0001-CMake-Locate-zstd-using-CONFIG.patch
* Tue Oct 20 2020 christophe@krop.fr
  - Update to 6.0.0beta1
    https://www.qt.io/blog/qt-6.0-beta-released
* Wed Oct 07 2020 christophe@krop.fr
  - Turn more options on:
    * link to openSSL
    * libproxy usage
* Tue Oct 06 2020 christophe@krop.fr
  - Update to 6.0.0-alpha
    https://www.qt.io/blog/qt-6.0-alpha-released
  - Import fix-fixqt4headers.patch from libqt5-qtbase
  - Add patches:
    * 0001-cmake-Fix-doc-installation.patch
    * 0001-cmake-Don-t-hardcode-the-library-directory-name.patch
* Sun Sep 20 2020 christophe@krop.fr
  - Resurrect 0001-Tell-the-truth-about-private-API.patch from
    libqt5-qtbase
* Tue Jan 21 2020 christophe@krop.fr
  - Add a qt6-printsupport-cups package for the cups plugin
  - Add the journald option back
* Tue Jan 21 2020 christophe@krop.fr
  - Split the changes into smaller commits
  - Fixed the wrong paths in CMake config files
  - Fixed the mkspecs install dir. Everything is in qt6_mkspecsdir now.
* Tue Dec 31 2019 christophe@krop.fr
  - Experimental qt6-qtbase package

Files

/usr/lib64/libQt6EglFSDeviceIntegration.so.6
/usr/lib64/libQt6EglFSDeviceIntegration.so.6.2.2
/usr/lib64/libQt6EglFsKmsGbmSupport.so.6
/usr/lib64/libQt6EglFsKmsGbmSupport.so.6.2.2
/usr/lib64/libQt6EglFsKmsSupport.so.6
/usr/lib64/libQt6EglFsKmsSupport.so.6.2.2
/usr/lib64/libQt6Gui.so.6
/usr/lib64/libQt6Gui.so.6.2.2
/usr/lib64/libQt6XcbQpa.so.6
/usr/lib64/libQt6XcbQpa.so.6.2.2
/usr/lib64/qt6/plugins/egldeviceintegrations
/usr/lib64/qt6/plugins/egldeviceintegrations/libqeglfs-emu-integration.so
/usr/lib64/qt6/plugins/egldeviceintegrations/libqeglfs-kms-egldevice-integration.so
/usr/lib64/qt6/plugins/egldeviceintegrations/libqeglfs-kms-integration.so
/usr/lib64/qt6/plugins/egldeviceintegrations/libqeglfs-x11-integration.so
/usr/lib64/qt6/plugins/generic
/usr/lib64/qt6/plugins/generic/libqevdevkeyboardplugin.so
/usr/lib64/qt6/plugins/generic/libqevdevmouseplugin.so
/usr/lib64/qt6/plugins/generic/libqevdevtabletplugin.so
/usr/lib64/qt6/plugins/generic/libqevdevtouchplugin.so
/usr/lib64/qt6/plugins/generic/libqlibinputplugin.so
/usr/lib64/qt6/plugins/generic/libqtslibplugin.so
/usr/lib64/qt6/plugins/generic/libqtuiotouchplugin.so
/usr/lib64/qt6/plugins/imageformats
/usr/lib64/qt6/plugins/imageformats/libqgif.so
/usr/lib64/qt6/plugins/imageformats/libqico.so
/usr/lib64/qt6/plugins/imageformats/libqjpeg.so
/usr/lib64/qt6/plugins/platforminputcontexts
/usr/lib64/qt6/plugins/platforminputcontexts/libcomposeplatforminputcontextplugin.so
/usr/lib64/qt6/plugins/platforminputcontexts/libibusplatforminputcontextplugin.so
/usr/lib64/qt6/plugins/platforms
/usr/lib64/qt6/plugins/platforms/libqeglfs.so
/usr/lib64/qt6/plugins/platforms/libqlinuxfb.so
/usr/lib64/qt6/plugins/platforms/libqminimal.so
/usr/lib64/qt6/plugins/platforms/libqminimalegl.so
/usr/lib64/qt6/plugins/platforms/libqoffscreen.so
/usr/lib64/qt6/plugins/platforms/libqvkkhrdisplay.so
/usr/lib64/qt6/plugins/platforms/libqvnc.so
/usr/lib64/qt6/plugins/platforms/libqxcb.so
/usr/lib64/qt6/plugins/platformthemes
/usr/lib64/qt6/plugins/xcbglintegrations
/usr/lib64/qt6/plugins/xcbglintegrations/libqxcb-egl-integration.so


Generated by rpm2html 1.8.1

Fabrice Bellet, Thu Jun 9 21:03:01 2022