Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

postgresql-server-16-150600.15.24 RPM for noarch

From OpenSuSE Leap 15.6 for noarch

Name: postgresql-server Distribution: SUSE Linux Enterprise 15
Version: 16 Vendor: SUSE LLC <https://www.suse.com/>
Release: 150600.15.24 Build date: Sat May 18 21:31:31 2024
Group: Productivity/Databases/Servers Build host: h04-ch2a
Size: 5650 Source RPM: postgresql-16-150600.15.24.src.rpm
Packager: https://www.suse.com/
Url: https://www.postgresql.org/
Summary: The Programs Needed to Create and Run a PostgreSQL Server
PostgreSQL is an advanced object-relational database management system
that supports an extended subset of the SQL standard, including
transactions, foreign keys, sub-queries, triggers, and user-defined
types and functions.

This package includes the programs needed to create and run a
PostgreSQL server, which will in turn allow you to create and maintain
PostgreSQL databases.

Provides

Requires

License

PostgreSQL

Changelog

* Thu Feb 08 2024 max@suse.com
  - bsc#1219340: Require fillup.
* Fri Oct 13 2023 max@suse.com
  - Interlock version and release of all noarch packages except for
    the postgresql-docs.
* Thu Sep 14 2023 max@suse.com
  - Bump default to 16 on Factory.
* Mon Aug 07 2023 max@suse.com
  - Bump major version to prepare for PostgreSQL 16, but keep
    default at 15 for now on Factory.
* Tue May 23 2023 max@suse.com
  - boo#1122892: Add a sysconfig variable for initdb.
* Mon May 15 2023 max@suse.com
  - Overhaul postgresql-README.SUSE and move it from the binary
    package to the noarch wrapper package.
  - bsc#1179231: Add an explanation for the /tmp -> /run/postgresql
    move and permission change.
  - Add postgresql-README as a separate source file.
* Mon Mar 27 2023 max@suse.com
  - bsc#1209208: Drop hard dependency on systemd
* Mon Jan 09 2023 max@suse.com
  - bsc#1206796: Refine the distinction of where to use sysusers and
    use bcond to have the expression only in one place.
* Thu Sep 22 2022 schwab@suse.de
  - riscv64 does not have llvm support yet,
    adapt the %postgresql_has_llvm macro accordingly.
* Mon Sep 05 2022 dmueller@suse.com
  - avoid bashisms in /bin/sh based startup script
* Sat May 21 2022 mrueckert@suse.de
  - Bump to postgresql 15
* Wed Mar 16 2022 gmbr3@opensuse.org
  - Change to systemd-sysusers
* Thu Feb 10 2022 max@suse.com
  - Fix the pg_server_requires macro on older rpm versions (SLE-12).
* Fri Jan 28 2022 max@suse.com
  - Avoid a dependency on awk in postgresql-script.
* Thu Dec 02 2021 max@suse.com
  - Move the dependency of llvmjit-devel on clang and llvm to the
    implementation packages where we can depend on the correct
    versions.
* Thu Dec 02 2021 mrueckert@suse.de
  - fix postgresql_has_llvm usage
* Mon Nov 15 2021 mrueckert@suse.de
  - First round of changes to make it easier to build extensions for
    - add postgresql-llvmjit-devel subpackage:
      This package will pull in clang and llvm if the distro has a
      recent enough version, otherwise it will just pull
      postgresql-server-devel.
    - add postgresql macros to the postgresql-server-devel package
      those cover all the variables from pg_config and some macros
      to remove repitition from the spec files
* Tue Oct 05 2021 max@suse.com
  - Bump version to 14.
  - Bump default to 14 on Factory and future SPs.
* Tue May 18 2021 max@suse.com
  - Re-enable build of the llvmjit subpackage on SLE, but it will
    only be delivered on PackageHub for now (boo#1183118).
* Mon Jan 25 2021 max@suse.com
  - Bump default version to 13 for SLE-15-SP3.
* Fri Sep 25 2020 max@suse.com
  - Bump major version to 13.
  - Bump default version to 13 in OBS.
* Thu Aug 13 2020 max@suse.com
  - We also transfer PostgreSQL 9.4.26 to the new package layout in
    SLE12-SP2 and newer. Reflect this in the conflict with
    postgresql94.
* Fri Jun 26 2020 max@suse.com
  - Also conflict with PostgreSQL versions before 9.
  - Conflicting with older versions is not limited to SLE.
* Tue Jun 16 2020 max@suse.com
  - Bump version to 12.0.1, so that the binary packages also have
    a cut-point to conflict with.
* Wed Jun 03 2020 max@suse.com
  - Disable LLVM on SLE (bsc#1172274).
  - Conflict with versions of the binary packages prior to the
    May 2020 update, because we changed the package layout at that
    point and need a clean cutover.
* Tue Mar 24 2020 max@suse.com
  - Bump package version to 12, but leave default at 10 for
    SLE-15 and SLE-15-SP1.
* Tue Dec 17 2019 max@suse.com
  - Fix a mistake in the creation of /var/lib/pgsql/.bash_profile
    with the tmpfiles mechanism (bsc#1159335).
* Thu Nov 14 2019 max@suse.com
  - Sync ownership of /run/postgresql in the file list with tmpfiles.
* Tue Oct 22 2019 mrueckert@suse.de
  - bump to 12
* Mon Oct 07 2019 max@suse.com
  - Use the correct content for .bash_profile (boo#1153168).
* Mon Sep 23 2019 max@suse.com
  - Stop shipping SUSEfirewall2 config files (bsc#1151591).
  - Fix installation of bash_profile for SLE11 (pre systemd).
* Fri Feb 22 2019 fbui@suse.com
  - Drop use of $FIRST_ARG in .spec
    The use of $FIRST_ARG was probably required because of the
    %service_* rpm macros were playing tricks with the shell positional
    parameters. This is bad practice and error prones so let's assume
    that no macros should do that anymore and hence it's safe to assume
    that positional parameters remains unchanged after any rpm macro
    call.
* Tue Feb 19 2019 max@suse.com
  - Change the persmissions for /var/run/postgresql to 1775, so that
    the directory can only be used by users in the postgres group
    (bsc#1123886).
* Thu Jan 31 2019 max@suse.com
  - Move bash profile out of /var/lib to allow transactional updates
    (bsc#1100397).
  - Use /run/postgresql instead of /var/run/postgresql in %ghost and
    postgresql-tmpfiles.conf to avoid rpmlint warnings and errors.
* Fri Nov 30 2018 mrueckert@suse.de
  - add /var/run/postgresql to the filelist. as %ghost for systemd
    systems and directly for non systemd systems
* Fri Nov 30 2018 mrueckert@suse.de
  - fix the unexpanded macro in the description of server-devel
* Thu Nov 15 2018 max@suse.com
  - Also bump the default package to 11.
* Wed Nov 07 2018 mrueckert@suse.de
  - add server-devel and llvmjit package file sections
* Thu Oct 25 2018 max@suse.com
  - Add the new subpackages server-devel and llvmjit that were
    introduced with postgresql11.
* Mon Jul 02 2018 mrueckert@suse.de
  - bump to 11
* Mon Apr 30 2018 dimstar@opensuse.org
  - Require update-alternatives by postgresql: one of the main
    scripts in use is install-alternatives, which calls u-a.
* Fri Feb 02 2018 max@suse.com
  - Put POSTGRES_LANG into LC_ALL instead of LANG to retain the
    previous behaviour of that variable (boo#1077027).
* Wed Jan 17 2018 max@suse.com
  - postgresql-script: /etc/sysconfig/language is deprecated, use the
    locale that was inherited from systemd instead for initializing
    a new database instance (boo#1074988).
* Wed Dec 13 2017 mrueckert@suse.de
  - add provides for all the pkgconfig() provides you also find in
    the postgresqlXY-devel packages. then we automatically will pull
    postgresql-devel which in turn will pull our default
    postgresqlXY-devel package. (boo#1071971)
* Wed Dec 06 2017 bruno@ioda-net.ch
  - Replace references to /var/adm/fillup-templates with new
    %_fillupdir macro (boo#1069468)
* Fri Nov 24 2017 mrueckert@suse.de
  - instead of hardcoding version 10, just check if the prio is
    smaller than 80.
* Thu Nov 23 2017 mrueckert@suse.de
  - simplify the postgresql-install-alternatives to only require the
    pg version and go from there.
    supported calls of the script are:
    /usr/share/postgresql/install-alternatives postgresqlXY
    /usr/share/postgresql/install-alternatives XY
    where XY can currently be: 92 93 94 95 96 10
* Wed Nov 22 2017 max@suse.com
  - CVE-2017-14798, bsc#1062722: Fix LPE via postgres init script.
    This only affected SysV-init based systems (i.e. SLE11).
* Tue Nov 14 2017 max@suse.com
  - postgresql-test was missing a %files section.
* Fri Nov 03 2017 max@suse.com
  - Move the start/stop script to /usr/share/postgresql
  - Add a script for handling update-alternatives as subpackages
    get installed/uninstalled, so that the implementation packages
    don't have to repeat the logic (postgresql-install-alternatives).
  - Add the postgresql-test subpackage.
  - Fix some dependencies.
  - Save the enabled and running state when upgrading from the
    obsolete postgresql-init package.
* Fri Oct 06 2017 mrueckert@suse.de
  - properly guard the systemd macro in %pre server so it wont be
    used on sle11
  - add Requires(pre) so we have groupadd/useradd available
* Thu Sep 21 2017 max@suse.com
  - Refine the dependencies between the "dummy" packages and the
    actual implementation of PostgreSQL. The dummy packages now
    require an arbitrary implementation and recommend the default
    version.
  - Move the contents of postgresql-init to the server package.
* Thu Aug 03 2017 mrueckert@suse.de
  - bump to 10
* Wed Jun 28 2017 max@suse.com
  - Bump version and defaultpackage to 9.6 in SLE12 (bsc#1046324).
* Sun Oct 30 2016 13ilya@gmail.com
  - Bump version and defaultpackage to 9.6 in Factory.
* Mon Sep 28 2015 max@suse.com
  - Move ~postgres/.bash_profile to postgresql-server to avoid a
    file conflict between the versioned server packages.
* Sun Aug 16 2015 ro@suse.de
  - Bump version and defaultpackage to 9.4. in SLE (bnc#941886)
* Wed Feb 18 2015 max@suse.com
  - Bump version and defaultpackage to 9.4 in Factory.

Files

/etc/sysconfig/SuSEfirewall2.d/services
/etc/sysconfig/SuSEfirewall2.d/services/postgresql
/run/postgresql
/usr/lib/systemd/system
/usr/lib/systemd/system/postgresql.service
/usr/lib/sysusers.d/postgresql-server.conf
/usr/lib/tmpfiles.d/postgresql.conf
/usr/sbin/rcpostgresql
/usr/share/doc/packages/postgresql-server
/usr/share/doc/packages/postgresql-server/README
/usr/share/fillup-templates/sysconfig.postgresql
/usr/share/postgresql/bash_profile
/usr/share/postgresql/postgresql-script
/var/lib/pgsql
/var/lib/pgsql/.bash_profile


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Jul 9 19:58:50 2024