Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libc++1-9.0.1-lp152.1.1 RPM for aarch64

From OpenSuSE Ports Leap 15.2 for aarch64

Name: libc++1 Distribution: openSUSE Leap 15.2
Version: 9.0.1 Vendor: openSUSE
Release: lp152.1.1 Build date: Tue Jun 2 19:52:08 2020
Group: System/Libraries Build host: obs-arm-4
Size: 823631 Source RPM: llvm9-9.0.1-lp152.1.1.src.rpm
Packager: https://bugs.opensuse.org
Url: https://libcxx.llvm.org/
Summary: C++ standard library implementation
This package contains libc++, a new implementation of the C++
standard library, targeting C++11.

Provides

Requires

License

Apache-2.0 WITH LLVM-exception OR NCSA

Changelog

* Fri Feb 07 2020 Richard Biener <rguenther@suse.com>
  - Add vim-plugin-llvm Conflicts to clang subpackage which now
    contains files formerly in llvmN-vim-plugins, conflicting with
    packages from older llvm releases.
* Thu Feb 06 2020 Richard Biener <rguenther@suse.com>
  - Add back emacs-llvm Provides and Conflicts to clang subpackage
    originally in llvm-emacs-plugins to properly conflict with
    llvm-emacs-plugins from older llvm releases.
* Tue Feb 04 2020 Richard Biener <rguenther@suse.com>
  - Add clang5-devel to clang9-doc conflicts.
* Mon Feb 03 2020 Andreas Schwab <schwab@suse.de>
  - Add compiler-rt-sanitizer-ipc-perm.patch: Fix sanitizer-common
    build with glibc 2.31.
* Wed Jan 29 2020 Aaron Puchert <aaronpuchert@alice-dsl.net>
  - Move clang-{format,include-fixer,rename}.{el,py} files from
    llvm-*-plugins to clang package. (boo#1161873)
  - Drop the now empty llvm-emacs-plugins package.
* Mon Jan 27 2020 Richard Biener <rguenther@suse.com>
  - Add polly and lld build conditionals, remove excessive Requires
    to clang from docs.  Fix conditional for libc++ use.
    [jsc#SLE-7400, jsc#SLE-7614, jsc#SLE-7452, jsc#SLE-8920, jsc#SLE-7390,
    jsc#SLE-7587]
* Wed Jan 15 2020 Aaron Puchert <aaronpuchert@alice-dsl.net>
  - Undo spec-cleaner changes that we don't want.
    * Reintroduce blank lines in configuration.
    * Use packageand syntax that works for older versions of RPM.
    * Don't use %{_bindir} on left-hand side of sed replacements.
* Sat Jan 11 2020 Andreas Schwab <schwab@suse.de>
  - riscv-eh-frame-fixup.patch: Remove changesets that alter the libLLVM ABI
* Wed Jan 08 2020 Jaime Caamaño Ruiz <jcaamano@suse.com>
  - Add upstream patch to export compiler-rt FuzzedDataProvider header,
    required by Envoy 1.12.2:
    * compiler-rt-move-fdp.patch
* Mon Jan 06 2020 Andreas Schwab <schwab@suse.de>
  - riscv-eh-frame-fixup.patch: Fix handling of .eh_frame on RISC-V
  - polly-pthread.patch: Add missing -lpthread
* Fri Jan 03 2020 Andreas Schwab <schwab@suse.de>
  - Enable support for riscv64
  - clang-riscv64-rv64gc.diff, riscv64-suse-linux.patch,
    llvm-riscv64-fix-cffi.diff, D60657-riscv-pcrel_lo.diff: Backports from
    master
* Fri Dec 20 2019 Aaron Puchert <aaronpuchert@alice-dsl.net>
  - Update to version 9.0.1.
    * This release contains bug-fixes for the LLVM 9.0.0 release.
      This release is API and ABI compatible with 9.0.0.
  - Drop patches that have landed upstream:
    * dont-install-example-analyzer-plugins.patch
    * fix-module-test.patch
    * llvm-add-missing-include.patch
  - Drop set-revision.patch, don't provide revision number in clang.
    The upstream repository has moved from Subversion to git, so the
    revision number is just a hash, which limits its usefulness.
  - Rebase llvm-do-not-install-static-libraries.patch.
* Thu Dec 05 2019 Aaron Puchert <aaronpuchert@alice-dsl.net>
  - Modify libcxx-tests-linux-distribution.patch to remove dependency
    on python-distro again: we don't have expected failures.
* Thu Dec 05 2019 Martin Liška <mliska@suse.cz>
  - Add llvm-add-missing-include.patch in order to fix
    boo#1158367.
* Tue Dec 03 2019 Aaron Puchert <aaronpuchert@alice-dsl.net>
  - Add gwp-asan-lto.patch: Make sure there are no LLVM IR files in
    static libraries that we package.
  - Add libcxx-tests-linux-distribution.patch (boo#1158293):
    Replace platform.linux_distribution by distro.linux_distribution.
  - Make documentation packages noarch.
* Mon Nov 04 2019 Aaron Puchert <aaronpuchert@alice-dsl.net>
  - Add openmp-export-fini.patch: Export termination function for
    libomp.so, solves boo#1155108.
  - Remove flaky test case in libcxx.
* Wed Oct 30 2019 Fabian Vogt <fvogt@suse.com>
  - Fix typo, BOLL -> BOOL
* Sat Oct 19 2019 Aaron Puchert <aaronpuchert@alice-dsl.net>
  - Let new {llvm,clang}*-doc packages "Conflict" with older devel
    packages, which they were split from.
  - Let doc packages conflict with older versions of themselves.
* Mon Oct 14 2019 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - (Build)Require only python3-base instead of full python3 package,
    the additional modules are not required. Helps shortening the
    build dependency chain.
  - Remove python3-* requires from lldb9 subpackage, and add it to
    the bindings/pretty-printer subpackage (python3-lldb9).
  - Add python3-base Requires to python3-clang subpackage
* Sat Sep 28 2019 Aaron Puchert <aaronpuchert@alice-dsl.net>
  - Add dont-install-example-analyzer-plugins.patch: Remove example
    analyzer plugins from install targets instead of deleting them.
  - Add fix-module-test.patch: fix test instead of deleting it.
  - Don't build static libc++ (with ThinLTO that's not useful anyway).
  - Don't build libc++experimental.
  - Don't package libc++abi.so with libc++-devel, it's already contained
    in the (required) libc++abi-devel.
  - Be more specific about files in libc++-devel.
* Sun Sep 22 2019 Aaron Puchert <aaronpuchert@alice-dsl.net>
  - Update to version 9.0.0.
    * For details, see the release notes:
    - https://releases.llvm.org/9.0.0/docs/ReleaseNotes.html
    - https://releases.llvm.org/9.0.0/tools/clang/docs/ReleaseNotes.html
    - https://releases.llvm.org/9.0.0/tools/clang/tools/extra/docs/ReleaseNotes.html
    - https://releases.llvm.org/9.0.0/projects/libcxx/docs/ReleaseNotes.html
    - https://releases.llvm.org/9.0.0/tools/lld/docs/ReleaseNotes.html
  - Change License to "Apache-2.0 WITH LLVM-exception OR NCSA".
    (https://llvm.org/foundation/relicensing/)
  - Allow building with ThinLTO and enable it on some architectures.
  - Disable LTO cache in lto-disable-cache.patch.
  - Unset MALLOC_CHECK_ for compilation to mitigate lock contention.
  - No debug info for ppc like for the other 32-bit targets.
  - Clean up _constraints: same constraints for 32-bit targets.
  - Don't use BUILD_SHARED_LIBS for Clang anymore, since the newly
    available libclang-cpp.so should expose the full C++ API.
  - Link tools with libclang-cpp.so by using CLANG_LINK_CLANG_DYLIB,
    similar to LLVM_BUILD_LLVM_DYLIB for libLLVM.so.
  - Remove obsolete n_clang_allow_BUILD_SHARED_LIBRARY.patch.
  - Add link-clang-shared.patch to link more clang targets with
    libclang-cpp.so, especially libclang.so.
  - Add link-clang-tools-extra-shared.patch, link-lldb-shared.patch:
    link targets in clang-tools-extra and lldb with libclang-cpp.so.
  - Simplify llvm-do-not-install-static-libraries.patch, also handle
    Clang, for which we now get static libraries.
  - Package documentation for llvm and clang separately, recommend
    them for the main package: they are not required for development,
    but actually useful for working with the non-devel packages.
  - Recommend editor plugins not just for llvm-devel.
  - Recommend libstdc++ for Clang again.
  - Move diagtool from llvm to clang subpackage.
  - Properly distinguish between %{_relver} and %{version}.
  - Drop aarch64-disable-memorytest.patch and reactivate test.
  - Rebase clang-resourcedirs.patch.
  - Rebase llvm-normally-versioned-libllvm.patch.
  - Rebase llvm-remove-clang-only-flags.patch.
  - Rebase llvm_build_tablegen_component_as_shared_library.patch.
  - Rebase set-revision.patch.
  - Increase disk space for build.
* Sun Sep 22 2019 Lubos Lunak <l.lunak@centrum.cz>
  - Make lldb recommend python3-lldb (it contains pretty printers).
* Wed Aug 21 2019 Aaron Puchert <aaronpuchert@alice-dsl.net>
  - Use python3 shebangs everywhere (boo#1146533).
  - Drop obsolete opt-viewer-Do-not-require-python-2.patch.
* Fri Aug 16 2019 Aaron Puchert <aaronpuchert@alice-dsl.net>
  - Remove unneccesary dependencies:
    * groff, bison and flex don't seem to be used.
    * jsoncpp is no longer used since r338461.
    * Move some BuildRequires to subpackages.
    * Don't recommend scan-{build,view} in clang (boo#1145444).
    * Devel packages are only required in other devel packages,
      when their headers are included in the installed headers.
  - Add versions to Provides/Conflicts except for files.
  - Remove unused (since r268685) CMake flags LLVM_ENABLE_TIMESTAMPS.
  - Fix installation of opt-viewer files when python3-clang is no
    longer built.
* Sat Jul 20 2019 Aaron Puchert <aaronpuchert@alice-dsl.net>
  - Update to version 8.0.1.
    * This release contains bug-fixes for the LLVM 8.0.0 release.
      This release is API and ABI compatible with 8.0.0.
  - Don't run LLVM tests on ppc at all because of sporadic hangs.
* Fri Jun 28 2019 Guillaume GARDET <guillaume.gardet@opensuse.org>
  - Increase RAM for armv6/7 to avoid OOM and be scheduled on fast
    worker
* Thu Jun 27 2019 Aaron Puchert <aaronpuchert@alice-dsl.net>
  - Use the documented LLVM_ENABLE_RTTI to enable RTTI instead of
    LLVM_REQUIRES_RTTI, which "is an internal flag that individual
    targets can use to force RTTI". (boo#1139584)
  - Drop obsolete llvm-build-tests-with-rtti.patch.
* Tue Jun 18 2019 Aaron Puchert <aaronpuchert@alice-dsl.net>
  - Exclude riscv64 for now since it fails to build.
* Sat Jun 15 2019 Aaron Puchert <aaronpuchert@alice-dsl.net>
  - Change some groups:
    * put libraries in System/Libraries,
    * devel packages in Development/Libraries,
    * clang in Development/Languages/C and C++,
    * the gold plugin in Development/Tools/Building.
  - Add some URLs, use https:// when possible.
  - Remove unneeded devel dependencies.
  - Only suggest a C++ standard library for clang. It's also a
    C compiler and needs no C++ library when only used as such.
  - Fix Supplements for editor plugins.
  - Fix some rpmlint issues:
    * Reword summary and description for Polly.
    * Fix /usr/bin/env shebangs.
    * Remove executable bit where not needed.
    * Move bash completion to /usr.
    * Remove hard dependency of libclang8 to libstdc++-devel.
  - Make rpm macros work properly.
  - Remove sources from documentation.
  - Run %fdupes on the right directories.
  - Enable tests for libcxx.
  - Reduce memory requirements for compile jobs depending on arch.
* Sun May 12 2019 Aaron Puchert <aaronpuchert@alice-dsl.net>
  - Avoid relocation overflow on ppc by not building GPU backends.
  - Update baselibs.conf.
* Wed Apr 24 2019 Martin Liška <mliska@suse.cz>
  - Disable LTO (boo#1133254).
* Sat Mar 23 2019 aaronpuchert@alice-dsl.net
  - Fix packaging on ppc: the sanitizers aren't available there, so
    the directories /usr/lib/clang/*/{lib,share} are missing.
  - Package LLVMgold even when we don't use gold for linking.
    It's promised in /usr/lib/cmake/llvm/LLVMExports.cmake.
  - Unignore test failures on PowerPC64 architectures. The failures
    in ppc are unrelated to AMDGPU, so we remove that remark.
  - Fix dependencies: the gold plugin shouldn't depend on llvm-devel.
    libc++abi-devel should depend on libc++abi.
  - Fix typo.
* Tue Mar 19 2019 Adrian Schröter <adrian@suse.de>
  - Enable libc++ on ARM (Needed for tensorflow)
* Mon Mar 11 2019 msrb@suse.com
  - Update to 8.0.0
    * For details, see the release notes:
      https://llvm.org/releases/8.0.0/docs/ReleaseNotes.html
      https://llvm.org/releases/8.0.0/tools/clang/docs/ReleaseNotes.html
      https://llvm.org/releases/8.0.0/tools/clang/tools/extra/docs/ReleaseNotes.html
      https://llvm.org/releases/8.0.0/tools/lld/docs/ReleaseNotes.html
  - Drop llvm-unittests-Don-t-install-TestPlugin.so.patch,
    llvm-drop-llvm-optional-clang-specific-optimization.patch,
    llvm-D51108.patch,
    llvm-Ensure-that-variant-part-discriminator-is-read-by-Me.patch,
    llvm-test-Fix-Assembler-debug-info.ll.patch
    * Already included upstream
  - Add 0001-CMake-Add-install-targets-for-utilities-to-LLVM-expo.patch
* Sun Mar 10 2019 aaronpuchert@alice-dsl.net
  - Remove -fno-strict-aliasing, which upstream doesn't use any more
    since r245304 in 2015. (http://reviews.llvm.org/D12036)
    It's probably also not needed for modern versions of GCC.
    It was enabled in r105644 because of some bugs there.
  - Add a clang-%{_sonum} symlink, which is referenced by
    /usr/lib64/cmake/clang/ClangTargets.cmake (boo#1120098)
  - Package clang builtin headers with libclang. The library is
    basically unusable without the builtin headers. Currently
    consumers of libclang have to require clang as well, although
    only the headers are needed.
* Tue Feb 26 2019 msrb@suse.com
  - llvm-Ensure-that-variant-part-discriminator-is-read-by-Me.patch,
    llvm-test-Fix-Assembler-debug-info.ll.patch
    * Fix crash in rustc (boo#1126907)
* Sun Feb 17 2019 John Paul Adrian Glaubitz <adrian.glaubitz@suse.com>
  - Allow use of Gold linker to be conditional
  - Disable Gold linker on ppc
    + LLVM currently doesn't build with Gold on ppc
* Tue Jan 15 2019 msrb@suse.com
  - Readd clang-7 and clang++-7 symlinks
    * Fixes uses of clang-devel (boo#1120098)
* Mon Jan 14 2019 msrb@suse.com
  - Update to llvm 7.0.1
    * This release contains bug-fixes for the LLVM 7.0.0 release.
      This release is API and ABI compatible with 7.0.0.
* Sun Dec 30 2018 Dirk Mueller <dmueller@suse.com>
  - enable gold unconditionally like with llvm6 and older
  - reenable openmp support again for aarch64 (like it was already in llvm6)
* Wed Dec 19 2018 Todd R <toddrme2178@gmail.com>
  - Use %license macro
  - Use upstream-recommended %{_rpmconfigdir}/macros.d directory
    for the rpm macros.
* Fri Dec 14 2018 John Paul Adrian Glaubitz <adrian.glaubitz@suse.com>
  - Remove ppc from Exclude field in spec file
  - Allow use of Gold linker to be conditional
  - Disable Gold linker on ppc
  - Add patch to fix SUSE GNU triplet on ppc
    * clang-fix-powerpc-triplet.patch
  - Add patch from upstream to fix ABI issue on ppc
    * llvm-D51108.patch
  - Limit list of enabled targets on ppc
    * PowerPC;AMDGPU;BPF;NVPTX
  - Ignore testsuite failures on ppc
* Tue Dec 11 2018 msrb@suse.com
  - llvm-drop-llvm-optional-clang-specific-optimization.patch
    * Fix ABI incompatibility when libLLVM (built with clang) is
      linked to a program build with gcc. (boo#1119092)
* Tue Oct 23 2018 msrb@suse.com
  - opt-viewer-Find-style-css-in-usr-share.patch
    * Make sure opt-viewer installed in /usr/bin can find resources
      from /usr/share/opt-viewer. (boo#1112730)
* Fri Oct 19 2018 msrb@suse.com
  - llvm-unittests-Don-t-install-TestPlugin.so.patch
    * It is only used for testing and is causing failures when
      processing LLVMExports.cmake.
* Tue Aug 28 2018 msrb@suse.com
  - Update to llvm 7.0.0
    * For details, see the release notes:
      https://llvm.org/releases/7.0.0/docs/ReleaseNotes.html
      https://llvm.org/releases/7.0.0/tools/clang/docs/ReleaseNotes.html
      https://llvm.org/releases/7.0.0/tools/clang/tools/extra/docs/ReleaseNotes.html
      https://llvm.org/releases/7.0.0/tools/lld/docs/ReleaseNotes.html
  - Remove no longer needed patches:
    * llvm6-fix-gdb-index-crash.patch
    * lldb-fix-build-with-python-3.7.patch
    * lldb-add-pthread-dl-libs.patch
    * polly-cmake-Trust-pkg-config-in-FindJsoncpp.patch
  - Add tests-use-python3.patch
    * Prevents tests from failing because of missing python 2.
  - Add llvm-better-detect-64bit-atomics-support.patch
    * Fixes build on i586.
* Mon Aug 27 2018 msrb@suse.com
  - Updated llvm-remove-clang-only-flags.patch
    - Exclude also "-Werror=unguarded-availability-new" (bsc#1106000)
* Wed Jul 25 2018 msrb@suse.com
  - Update to llvm 6.0.1
    * This release contains bug-fixes for the LLVM 6.0.0 release. It
      is API and ABI compatible with 6.0.0.
  - Remove no longer needed llvm6-fix-InstCombine.patch
  - Add lldb-fix-build-with-python-3.7.patch
    * Fix build with python 3.7
* Fri Jun 29 2018 l.lunak@centrum.cz
  - llvm6-fix-gdb-index-crash.patch
    * From upstream, fix lld --gdb-index crash.
* Thu Jun 14 2018 msrb@suse.com
  - Do not requires gcc6 for older sle versions.
    * llvm6 is not built on <= 12 SP3 and this was preventing build
      on 12 SP4.
* Thu May 17 2018 msrb@suse.com
  - llvm_build_tablegen_component_as_shared_library.patch
    * Build TableGen component as its own shared library because it
      is not included in the libLLVM library and is needed for ldc.
      (bsc#1086445)
* Thu May 17 2018 tchvatal@suse.com
  - Add patch llvm6-fix-InstCombine.patch to fix InstCombine init
    * Will be fixed in 6.0.1 release
* Wed May 09 2018 msrb@suse.com
  - Do not build stage1 with debug info. It was accidentally added
    with the use of %optflags. This should fix out of memory errors
    on 32bit architectures and speed up build everywhere else.
    (bsc#1092697)
* Wed Apr 11 2018 msrb@suse.com
  - llvm-build-tests-with-rtti.patch
    * Fixes build failure with gcc 8. (bnc#1087136)
* Thu Apr 05 2018 msrb@suse.com
  - Do not export Polly static libraries which we do not distribute.
    * Updated llvm-do-not-install-static-libraries.patch
  - Use external jsoncpp instead of the bundled one.
    * Added polly-cmake-Trust-pkg-config-in-FindJsoncpp.patch
  - llvm6-devel must require llvm6-polly-devel
    * Files in llvm6-devel reference Polly.
* Mon Mar 19 2018 msrb@suse.com
  - Update to llvm 6.0.0
    * Added polly
    * Notable changes:
    - Retpoline Spectre variant 2 mitigation
    - GlobalISel by default for AArch64 at -O0
    - improved scheduling on several x86 micro-architectures
    - Clang defaults to -std=gnu++14 instead of -std=gnu++98
    - support for some upcoming C++2a features
    - improved optimizations, new compiler warnings, many bug
      fixes, and more.
  - Use alternatives for clang's bash autocomplete to prevent
    conflicts with other versions.
* Thu Feb 15 2018 msrb@suse.com
  - Remove liblldb5 and lldb5-devel from baselibs.conf. They are only
    build for x86_64, so no point having them in baselibs.conf.
* Wed Feb 07 2018 msrb@suse.com
  - Use %optflags, except for FORTIFY_SOURCE which is not compatible
    with compiler-rt.
  - Exclude static libraries differently.
    * Drop llvm-split-static-library-exports-into-their-own-export-file.diff
    * Drop clang-split-static-library-exports-into-their-own-export-file.diff
    * Update llvm-do-not-install-static-libraries.patch to not use
      EXCLUDE_FROM_ALL which is not available in cmake 3.5.
    - This fixes build on SLE12.
  - Do not force gcc6 on OpenSUSE - fixes build.
  - Reduce the amount of concurent link jobs by increasing their
    memory requirement - to reduce stalls in OBS.
* Wed Jan 31 2018 msrb@suse.com
  - Cleanup %ifarch conditions, remove targets unintentionally added
    to s390/s390x. (bnc#1078436)
* Tue Jan 30 2018 msrb@suse.com
  - Limit the amount of parallel link jobs, but no longer limit
    compile jobs. This should prevent running out of memory during
    linking while not longer slowing down compilation.
  - Remove build dependency on procps
* Mon Jan 29 2018 msrb@suse.com
  - Reduce disk size requirement to 30GB in _constraints. We no
    longer need that much since we stopped building static libraries.
* Thu Jan 18 2018 msrb@suse.com
  - n_clang_allow_BUILD_SHARED_LIBRARY.patch
    * Allow buildling clang with BUILD_SHARED_LIBRARY while the rest
      is built with LLVM_LINK_LLVM_DYLIB. (bnc#1065464)
  - Remove clang-devel-static.
* Wed Jan 10 2018 msrb@suse.com
  - Place gold plugin to the right directory. (bnc#1073210)
    * It must be in /usr/lib/bfd-plugins on all architectures.
    * Remove llvm5-gold from baselibs.conf - nothing needs a 32bit
      version of it and it would now conflict with the 64bit one.
  - Reduce _constraints requirements on 32bit architectures.
    * Since we had to disable debuginfo on them, they require much
      less.
* Wed Jan 10 2018 normand@linux.vnet.ibm.com
  - ignore make check error for PowerPC as bypass
    https://bugs.llvm.org/show_bug.cgi?id=35871
* Mon Jan 08 2018 dmueller@suse.com
  - disable debuginfo build for ARM as well
* Fri Jan 05 2018 msrb@suse.com
  - Delete intermediate files during build to reduce total disk usage
    (bnc#1074625)
* Thu Jan 04 2018 msrb@suse.com
  - Update to llvm 5.0.1
    * This release contains bug-fixes for the LLVM 5.0.0 release.
    * This release is API and ABI compatible with 5.0.0.
  - llvm-do-not-install-static-libraries.patch
    * Updated.
* Fri Dec 22 2017 fcrozat@suse.com
  - Increase minimum memory and disk sizes required for building in
    _constraints.
* Wed Dec 13 2017 msrb@suse.com
  - Rename python3-lldb to python3-lldb5 so it can work with llvm
    meta package.
* Mon Dec 11 2017 msrb@suse.com
  - Rename python packages to follow naming conventions.
  - Remove unnecessary dependencies on python3.
  - Make opt-viewer not require python2.
    * opt-viewer-Do-not-require-python-2.patch
* Mon Dec 04 2017 msrb@suse.com
  - Switch to python3.
  - Fix %check tests when used with python3.
    * Define LANG=C.UTF-8 when running the tests.
  - Add explicit Provides/Conflicts to llvm5-devel,
    clang5-devel-static and lldb5-devel.
    * These are required to be validated by obs repo-checker.
* Fri Dec 01 2017 msrb@suse.com
  - Use LLVM_OPTIMIZED_TABLEGEN to speed up build. (bnc#1064786)
  - Fix files of lldb4 to work correctly with update-alternatives.
  - Remove Conflicts clang(LLDB) from lldb4-devel - it does not
    exist. It would be provided automatically, but no such cmake file
    is installed.
  - llvm-do-not-install-static-libraries.patch
    * Do not install static libraries instead of installing them and
      deleting after.
    * Reduces disk usage during build. (bnc#1064786)
  - Do not build unnecessary parts during stage1.
    * Speeds up build a bit. (bnc#1064786)
* Mon Nov 20 2017 msrb@suse.com
  - Updated baselibs.conf to reference version 5 packages.
  - Deleted rogue llvm5.spec.r29 file.
  - Deleted arm_suse_support.diff, llvm-add_a_LLVM_USE_LINKER.patch,
    libsanitizer.patch.
    - No longer used, applied already in the source.
* Tue Oct 17 2017 msrb@suse.com
  - llvm-normally-versioned-libllvm.patch
    * Change libLLVM naming scheme to match our naming guidelines.
    * The reasons for the original naming scheme are no longer valid,
      more details in the patch.
* Fri Oct 13 2017 msrb@suse.com
  - Disable all thread related tests in libcxx. Many of them use
    timeouts to detect failure. They can fail randomly if the machine
    is under heavy load (happens often in OBS).
* Tue Oct 10 2017 msrb@suse.com
  - Drop llvm5-devel-static. llvm5-devel contains shared library with
    the same content.
* Mon Oct 09 2017 msrb@suse.com
  - Increase disk space requirement in _constraints to 45GB.
    Otherwise the build gets stuck in random places.
  - Skip build of lldb5 python on distributions with swig < 3.0.11
* Wed Aug 30 2017 msrb@suse.com
  - Copy from llvm4.
  - Update to llvm 5.0.0.
* Wed Aug 30 2017 msrb@suse.com
  - Use LLVM_BUILD_LLVM_DYLIB instead of BUILD_SHARED_LIBS to build
    single libLLVM library. This is the recommended way. The old way
    was causing various issues.
    * llvm-split-static-library-exports-into-their-own-export-file.diff
    * clang-split-static-library-exports-into-their-own-export-file.diff
    (bnc#1049703)
  - Add lld, linker for Clang/LLVM
    (sr#517692)
  - Include clang++-MAJOR.MINOR symbolic link
    (bnc#1012260)
  - Remove unnecessary dependency on flex and bison.
  - Make sure all binaries are managed by update-alternatives
  - Add llvm-add_a_LLVM_USE_LINKER.patch and link using gold to
    prevent memory exhaustion on some build machines.
  - Reduce debuginfo on x86 architecture. LLVM libraries are so big that they
    exhaust all memory on 32 bit machine if linked with full debuginfo.
  - Speed up build by skipping parts that are not required in stage1.
  - Build lldb in-tree as one of the llvm tools.
* Tue Aug 29 2017 meissner@suse.com
  - clang-ignore-stack-clash-protector.patch: ignore -fstack-clash-protection
    for now.
* Tue Aug 08 2017 schwab@suse.de
  - xlocale.patch: don't use obsolete <xlocale.h>
  - libsanitizer.patch: fix use of undocumented types
* Sun Jul 16 2017 dmueller@suse.com
  - build fixes for armv6 (skip testsuite as it requires 64bit,
    set the list of targets to include ARM and remove triplet hack)
* Sat Jul 01 2017 jimmy@boombatower.com
  - Include provides and conflics in baselibs.conf for llvm4-devel,
    clang4-devel, llvm4-LTO-devel, and llvm4-gold.
* Mon Jun 26 2017 idonmez@suse.com
  - Update to version 4.0.1
    * Minor bugfixes
* Fri Jun 02 2017 idonmez@suse.com
  - Use gcc6 only for SLE boo#1041469
* Tue May 09 2017 idonmez@suse.com
  - Package libLLVMFuzzer
* Wed Apr 19 2017 dmueller@suse.com
  - readd arm_suse_support.diff which was accidentally removed
    in the 4.0.0 update
* Wed Apr 05 2017 afaerber@suse.de
  - Enable AMDGPU and NVPTX targets everywhere except for S/390.
    The AMDGPU target is needed for Mesa Clover (sr#485802).
* Tue Apr 04 2017 idonmez@suse.com
  - Use gcc6 on SLE12
* Thu Mar 30 2017 idonmez@suse.com
  - Package license & credits
* Mon Mar 27 2017 idonmez@suse.com
  - Update to version 4.0.0
    * See
      + http://releases.llvm.org/4.0.0/docs/ReleaseNotes.html and
      + http://releases.llvm.org/4.0.0/tools/clang/docs/ReleaseNotes.html
      + http://releases.llvm.org/4.0.0/tools/clang/tools/extra/docs/ReleaseNotes.html
  - Drop the following patches, fixed upstream:
    amdgpu_revert_r280589.patch
    arm_suse_support.diff
    clang-fix-substitutions-abi_tag.patch
    clang-incomplete-field-types.patch
    glibc-2.24-libcxx.patch
    llvm-install-CheckAtomic.patch
    revert-cmake-soname.patch
* Fri Feb 24 2017 idonmez@suse.com
  - Enable BPF for all arches bsc#1026191
* Wed Jan 25 2017 idonmez@suse.com
  - libc++ must depend on libc++abi
* Wed Jan 25 2017 idonmez@suse.com
  - Stop using otherproviders() due to an rpm parser bug, use
    self-conflicts instead as suggested by mls.
* Tue Jan 24 2017 idonmez@suse.com
  - Add amdgpu_revert_r280589.patch to fix an amdgpu regression
    bsc#1021577
* Tue Jan 17 2017 jslaby@suse.com
  - Require LLVMgold and libLTO in llvm-devel, otherwise we get in CMake:
    The imported target "LLVMgold" references the file
    "/usr/lib64/LLVMgold.so" but this file does not exist.
    This happens when requiring llvm3_9-devel directly, not llvm-devel.
* Wed Dec 21 2016 idonmez@suse.com
  - Update to version 3.9.1
    * See:
      + http://llvm.org/releases/3.9.1/docs/ReleaseNotes.html
      + http://llvm.org/releases/3.9.1/tools/clang/docs/ReleaseNotes.html
      + http://llvm.org/releases/3.9.1/tools/clang/tools/extra/docs/ReleaseNotes.html
* Wed Sep 28 2016 toddrme2178@gmail.com
  - Update to version 3.9.0
    * Clang now supports the G++ abi_tag attribute.
    * Clang will no longer pass --build-id by default to the linker.
    * Improved C++1z support in Clang.
    * Clang now has support for all OpenCL 2.0 features.
    * Added support for all non-offloading features from OpenMP 4.5,
    * The static analyzer now checks for incorrect usage of MPI APIs in C and C++.
    * LLVM no longer does inter-procedural analysis and optimization
      (except inlining) on functions with comdat linkage.
    * LLVM now supports the Intel CPUs Skylake Server with AVX512
      (-march=skylake-avx512) and Knights Landing (-march=knl).
    * More at:
      + http://llvm.org/releases/3.9.0/docs/ReleaseNotes.html
      + http://llvm.org/releases/3.9.0/tools/clang/docs/ReleaseNotes.html
      + http://llvm.org/releases/3.9.0/tools/clang/tools/extra/docs/ReleaseNotes.html
    * Fix the following patches:
      + arm_suse_support.diff
      + assume-opensuse.patch
      + clang-resourcedirs.patch
      + default-to-i586.patch
      + glibc-2.23-libcxx.patch
      + glibc-2.24-libcxx.patch
      + lldb-add-pthread-dl-libs.patch
      + lldb-cmake.patch
      + llvm-fix-find-gcc5-install.patch
      + llvm-remove-clang-only-flags.patch
      + revert-cmake-soname.patch
      + set-revision.patch
    * Remove upstream-included patch:
      + llvm-nonvoid-return.patch
    * Remove patch for removed files:
      + glibc-2.23-libcxx.patch
  - Backport upstream patches:
    * clang-fix-substitutions-abi_tag.patch
    * clang-incomplete-field-types.patch
    * llvm-install-CheckAtomic.patch
  - Add clang%{_sonum}-include-fixer subpackage and associated
    libfindAllSymbols%{_sonum} and libfindAllSymbols%{_sonum}-devel
    subpackages.
  - Add sanstats to llvm binary list.
* Fri Sep 23 2016 toddrme2178@gmail.com
  - Change update-alternatives to use %postun instead of %preun,
    which is now what Factory maintainers are requesting.
  - Use the minor version to set the update-alternatives priority so
    the most recent version of the LLVM, Clang, and LLDB are used by
    default.
  - Add LLVM rpm macros so downstream packages can have some idea how
    LLVM was built.
* Tue Sep 20 2016 toddrme2178@gmail.com
  - Rename libomp to make it possible to have multiple versions available.
* Fri Sep 09 2016 toddrme2178@gmail.com
  - Split the old llvm package into this version-specific package
    and a wrapper package.
  - Implement update-alternatives to allow parallel installation
    of many of the subpackages.
  - Rename subpackages that can be parallel-installed to a
    version-specific name based on the associated shared library's
    current .so number.
  - Various fixes to support the above changes.
* Wed Sep 07 2016 tchvatal@suse.com
  - Sort a bit with spec-cleaner
  - Remove the latest switch for now, things should be either coinstallable
    or not, we don't need to bother around with compilation like this
* Wed Aug 31 2016 toddrme2178@gmail.com
  - Update to llvm 3.8.1
    * See http://llvm.org/releases/3.8.1/docs/ReleaseNotes.html and
      http://llvm.org/releases/3.8.1/tools/docs/ReleaseNotes.html
  - Use versioned libLLVM (to libLLVM3_8) and libclang (to libclang3_8)
  - Change versioning of liblldb3_8 to liblldb-3_8 and use a variable
    to control the name instead of hard-coding it.
  - Use bcond_with and bcond_without to enable/disable build options
    instead of hard-coding them.
  - Put buildrequires as requires in -devel packages to avoid linker errors
    when building packages against the -devel packages.
  - Add ffi support (disabled by default).
  - Add oprofile support (disabled by default).
  - Add valgrind support (disabled by default).
  - Link cmake files to the normal cmake file directory to allow autodetection
    of cmake interfaces.
  - Remove unused lldb components from main spec file.
  - Split llvm python bindings into own subpackage.
  - Split emacs plugin into own subpackage
  - Move additional vim plugins into vim plugins package
  - Split libc++, libLTO, LLVMgold, libomp, clang-chekers into own subpackages
  - Make python-clang, llvm-vim-plugins, and llvm-emacs-plugins noarch since
    they aren't architecture-specific.
  - Make packages besides llvm, llvm-clang, and the shared libraries conflict
    with other versions.  This will be important when multiple LLVM versions
    are supported.
  - Various spec file cleanups
  - Rebase patches:
    * arm_suse_support.diff
    * assume-opensuse.patch
    * clang-resourcedirs.patch
    * default-to-i586.patch
    * glibc-2.23-libcxx.patch
    * glibc-2.24-libcxx.patch
    * lldb-add-pthread-dl-libs.patch
    * lldb-cmake.patch
    * llvm-fix-find-gcc5-install.patch
    * llvm-nonvoid-return.patch
    * llvm-remove-clang-only-flags.patch
    * revert-cmake-soname.patch
    * set-revision.patch
* Fri Aug 26 2016 tchvatal@suse.com
  - Start conversion to use cmake macros with now introduced
    compatibility for ninja
  - Reduce number of threads if we don't have enough memory
  - Add patch for the nonvoid returns:
    * llvm-nonvoid-return.patch
* Thu Jul 28 2016 normand@linux.vnet.ibm.com
  - for ppc64le set memory to 4GB in _constraints file
    (failure in Factory:PowerPC)
* Wed Jul 13 2016 schwab@suse.de
  - glibc-2.24-libcxx.patch: fix libcxx testsuite for glibc 2.24
* Wed May 18 2016 ronisbr@gmail.com
  - Build LLDB separated from LLVM.
  - Re-enable python bindings for the LLDB API.
* Wed May 18 2016 idonmez@suse.com
  - Disable libcxx/lldb/openmp for SLE fate#319582
* Mon Apr 25 2016 idonmez@suse.com
  - Update rpmlintrc to whitelist libLTO.so
* Mon Apr 11 2016 idonmez@suse.com
  - Re-enable glibc-2.23 patch for Tumbleweed
* Sun Apr 10 2016 dmueller@suse.com
  - fix arm_suse_support.diff for armv6hl
  - adjust compile flags for llvm on armv6hl (fixes Mesa build)
* Mon Apr 04 2016 idonmez@suse.com
  - Update llvm-remove-clang-only-flags.patch to remove
    - Wcovered-switch-default flag for gcc compatibility.
* Wed Mar 16 2016 idonmez@suse.com
  - Use gcc for stage1 bootstrap
  - Add back libstdc++-devel dependency for clang since libc++ is
    only available for x86-64 atm.
* Thu Mar 10 2016 idonmez@suse.com
  - Comment out glibc-2.23-libcxx.patch until glibc 2.23 actually
    hits the Factory.
* Tue Mar 08 2016 idonmez@suse.com
  - Update to llvm 3.8.0
    * See http://llvm.org/releases/3.8.0/docs/ReleaseNotes.html and
      http://llvm.org/releases/3.8.0/tools/clang/docs/ReleaseNotes.html
  - Fold lldb build into llvm and disable python support
  - Drop clang-disable-ada-extension.patch, libcxxabi-exceptions.patch
    and cmake-host-triple.patch
  - Add revert-cmake-soname.patch to fix soname handling
* Wed Mar 02 2016 idonmez@suse.com
  - Add glibc-2.23-libcxx.patch to fix test failures with glibc 2.23
* Sat Oct 03 2015 mimi.vx@gmail.com
  -  Remove FFI support because its fragile
* Sun Sep 27 2015 idonmez@suse.com
  - Enable OpenMP for x86, x86_64, ppc64 and ppc64le
* Mon Sep 14 2015 idonmez@suse.com
  - Enable all targets on x86, x86_64
* Wed Sep 02 2015 idonmez@suse.com
  - Update to version 3.7.0
    * See http://llvm.org/releases/3.7.0/docs/ReleaseNotes.html
  - Merge aarch64-suse-support.patch into arm_suse_support.diff
  - Refresh arm_suse_support.diff, llvm-fix-find-gcc5-install.patch
  - Remove llvm-fix-parsearmarch.patch, upstream.
* Tue May 26 2015 ro@suse.de
  - fix build on s390x (one typo in ifarch and one change in filelist)
* Mon May 25 2015 idonmez@suse.com
  - Update to version 3.6.1
    * No changelog upstream
* Fri Apr 24 2015 idonmez@suse.com
  - Add llvm-fix-parsearmarch.patch to fix parsing armv{6,7}hl archs.
* Mon Mar 02 2015 idonmez@suse.com
  - Update to version 3.6.0
    * See http://llvm.org/releases/3.6.0/docs/ReleaseNotes.html
  - Add python-xml dependency for regression tests
  - Removed the following patches, fixed upstream:
    * arm-remove-xfails.diff
    * libcxx-libdir.patch
    * llvm-config-lib64.patch
    * llvm-fix-intrusiverefcntptr.patch
* Fri Feb 20 2015 rguenther@suse.com
  - Add llvm-fix-intrusiverefcntptr.patch to fix build of LLVM tools
    with GCC 5.
  - Add llvm-fix-find-gcc5-install.patch to properly find installed GCC 5.
* Wed Jan 28 2015 idonmez@suse.com
  - Add a gcc dependency for clang, this is heavyweight but we need
    libgcc_s which comes with the gcc package (bnc#893359)
* Fri Dec 12 2014 idonmez@suse.com
  - Conditionalize libcxx{abi} build on build_libcxx variable
  - Turn libc++.so into an ldscript so it links to libc++abi
    automatically.
* Tue Oct 21 2014 dmueller@suse.com
  - fix constraints for armv6l/armv7l (there is no 4GB RAM on 32bit)

Files

/usr/lib64/libc++.so.1
/usr/lib64/libc++.so.1.0
/usr/share/licenses/libc++1
/usr/share/licenses/libc++1/CREDITS.TXT
/usr/share/licenses/libc++1/LICENSE.TXT


Generated by rpm2html 1.8.1

Fabrice Bellet, Wed Jun 9 17:05:39 2021