Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libqca-qt5-2-2.3.4-2.5 RPM for armv7hl

From OpenSuSE Ports Tumbleweed for armv7hl

Name: libqca-qt5-2 Distribution: openSUSE Tumbleweed
Version: 2.3.4 Vendor: openSUSE
Release: 2.5 Build date: Wed Jun 15 21:52:24 2022
Group: Unspecified Build host: obs-arm-11
Size: 961872 Source RPM: qca-qt5-2.3.4-2.5.src.rpm
Packager: http://bugs.opensuse.org
Url: https://userbase.kde.org/QCA
Summary: QCA library
The Qt cryptographic library.

Provides

Requires

License

LGPL-2.1-or-later

Changelog

* Thu Oct 21 2021 Christophe Giboudeaux <christophe@krop.fr>
  - Set LD_LIBRARY_PATH before running tests.
* Tue Sep 14 2021 Fabian Vogt <fabian@ritter-vogt.de>
  - Run ctest in %check
  - Add patch to make %check much quicker:
    * 0001-Make-filewatchunittest-much-quicker.patch
* Tue Sep 14 2021 Fabian Vogt <fabian@ritter-vogt.de>
  - Update to 2.3.4:
    * OpenSSL 3 support
    * Don't create pkgconfig files for Qt 6 builds
    * Minor test fix
* Fri Jun 18 2021 Fabian Vogt <fabian@ritter-vogt.de>
  - Mention soversion in %files
  - Require main plugins from the library (for now, boo#1187447)
  - Recommend optional plugins from the library
* Wed Jun 16 2021 Wolfgang Bauer <wbauer@tmo.at>
  - Recommend the main package in the Qt5 flavor as well
* Fri Jun 04 2021 Christophe Giboudeaux <christophe@krop.fr>
  - Rename libqca-qt5 to qca and use flavors to build Qt5 and Qt6
    variants.
* Thu Jun 03 2021 Wolfgang Bauer <wbauer@tmo.at>
  - Update to 2.3.3:
    * Add Qt6 support. Use -DQT6=ON when running cmake
    * Minimum Qt5 supported version updated to 5.14
    * Minor doc fixes
  - Rebase qca-2.3.0-fixDSA.patch
* Thu Feb 11 2021 Christophe Giboudeaux <christophe@krop.fr>
  - Add a keyring file
  - Use cmake() syntax for Qt build requirements
* Fri Feb 05 2021 Paolo Stivanin <info@paolostivanin.com>
  - Update to 2.3.2:
    * Add macOS framework major version
    * qca-gcrypt: Add support for HKDF
    * Minimum Qt updated to 5.9
    * Fixed compilation with gcc 11
  - Rebase qca-2.3.0-fixDSA.patch
* Mon Jul 06 2020 Wolfgang Bauer <wbauer@tmo.at>
  - Update to 2.3.1
    * fixes memleaks and crashes
* Tue Mar 10 2020 Antonio Larrosa <alarrosa@suse.com>
  - Remove baselibs.conf
* Wed Feb 26 2020 Wolfgang Bauer <wbauer@tmo.at>
  - Update to 2.3.0
    * Qt5 is the only supported Qt series now
    * OpenSSL <= 1.1.0 is no longer supported
    * Various botan bugfixes
    * More dynamic test coverage of backend capabilities
    * no longer tries to setuid when the effective uid is not root
  - Rename qca-2.2.1-fixDSA.patch to qca-2.3.0-fixDSA.patch and
    rebase it
  - Update minimum required Qt5 and cmake versions
* Mon Sep 09 2019 Christophe Giboudeaux <christophe@krop.fr>
  - Drop the obsolete libqca2 package.
  - Run spec-cleaner
* Fri Apr 26 2019 Fabian Vogt <fabian@ritter-vogt.de>
  - Fix source URL
* Fri Apr 26 2019 Wolfgang Bauer <wbauer@tmo.at>
  - Update to 2.2.1
    * support for openssl 1.1
    * support for AES GCM and AES CCM modes
    * new base64 convenience functions
    * new botan2 support
    * new hkdf support
    * various build improvements and (deprecation) cleanups
  - Drop patches merged upstream:
    * 0001-Revert-tlsunittest-disable-some-ciphers.patch
    * 0002-Disable-missed-openssl-cipher-suites.patch
    * 0003-Add-support-for-OpenSSL-1.1.0.patch
    * ansi.diff
  - Rename qca-2.1.3-fixDSA.patch to qca-2.2.1-fixDSA.patch and
    rebase it
  - Re-enable pkcs11, there is no openssl conflict anymore
  - Don't hardcode the certstore path anymore, ca-certificates is
    BuldRequired so this can be detected automatically

Files

/usr/lib/libqca-qt5.so.2
/usr/lib/libqca-qt5.so.2.3.4
/usr/share/doc/packages/libqca-qt5-2
/usr/share/doc/packages/libqca-qt5-2/README
/usr/share/licenses/libqca-qt5-2
/usr/share/licenses/libqca-qt5-2/COPYING


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Aug 9 11:13:25 2022