Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libcrack2-2.9.7-lp152.2.3.1 RPM for x86_64

From OpenSuSE Leap 15.2 updates for x86_64

Name: libcrack2 Distribution: openSUSE Leap 15.2
Version: 2.9.7 Vendor: openSUSE
Release: lp152.2.3.1 Build date: Thu Dec 2 08:12:13 2021
Group: System/Libraries Build host: lamb66
Size: 39352 Source RPM: cracklib-2.9.7-lp152.2.3.1.src.rpm
Packager: http://bugs.opensuse.org
Url: http://sourceforge.net/projects/cracklib
Summary: Library to crack passwords using dictionaries
CrackLib tests passwords to determine whether they match
certainsecurity-oriented characteristics. You can use CrackLib to
stopusers from choosing passwords that are too simple.This package
contains a full dictionary file used by cracklib.

Provides

Requires

License

LGPL-2.1-only

Changelog

* Fri Nov 12 2021 pgajdos@suse.com
  - %check: really test the package [bsc#1191736]
* Tue Jun 02 2020 Michael Gorse <mgorse@suse.com>
  - Update to version 2.9.7:
    + fix a buffer overflow processing long words.
  - Drop 0003-overflow-processing-gecos.patch and
    0004-overflow-processing-long-words.patch: fixed upstream.
  - Update source URI.
  - Remove use of translation-update-upstream. It cannot be added to
    ring 0 on leap, and 2.9.7 has some translation fixes
    (bsc#1172396).
* Fri May 22 2020 Michael Gorse <mgorse@suse.com>
  - Enable translation-update-upstream on leap, to remove the use of
    is_opensuse (jsc#SLE-12096).
* Wed May 06 2020 pgajdos@suse.com
  - use /usr/lib instead of %{_libexecdir}, %{_libexecdir} should
    contain internal binaries, not data
* Thu Feb 22 2018 fvogt@suse.com
  - Use %license (boo#1082318)
* Sat Nov 11 2017 aavindraa@gmail.com
  - Update to 2.9.6
    * fix issue with sort and locale
    * some particularly bad cases to the cracklib small dictionary
    * updates to cracklib-words (adds a bunch of other dictionary lists)
    * migration to github
  - run spec-cleaner
* Mon Dec 12 2016 dimstar@opensuse.org
  - Only buildrequire and call translation-update-upstream on SLE:
    the package in openSUSE is a dummy and is empty.
* Wed Aug 17 2016 hguo@suse.com
  - Add patch 0004-overflow-processing-long-words.patch
    to fix a new buffer overflow identified together with bsc#992966.
* Mon Aug 15 2016 hguo@suse.com
  - Relabel patches:
    cracklib-magic.diff -> 0001-cracklib-magic.diff
    cracklib-2.9.2-visibility.patch -> 0002-cracklib-2.9.2-visibility.patch
  - Add patch 0003-overflow-processing-gecos.patch
    to fix a buffer overflow in GECOS parser (bsc#992966 CVE-2016-6318)
* Tue Aug 18 2015 mpluskal@suse.com
  - Update to 2.9.5
    * fix matching against first password in dictionary (Anton Dobkin)
  - Changes for 2.9.4
    * remove doubled prototype
  - Changes for 2.9.3
    * expose additional functions externally
* Fri Apr 03 2015 mpluskal@suse.com
  - Cleanup spec file with spec-cleaner
  - Remove old ppc provides/obsoletes
* Sun Jan 04 2015 p.drouand@gmail.com
  - Update to version 2.9.2
    + support build of python support outside of source tree
    + fix bug in Python string distance calculation
    + fix bug #16 / debian bug 724570 - broken optimization with packlib
      prevblock
  - Adapt patch to upstream changes
    + cracklib-visibility.patch > cracklib-2.9.2-visibility.patch

Files

/usr/lib64/libcrack.so.2
/usr/lib64/libcrack.so.2.9.0


Generated by rpm2html 1.8.1

Fabrice Bellet, Mon May 9 13:08:06 2022