9.2. 텍스트 파일 편집하기

Red Hat Linux에는 평문 파일을 보고 수정하는데 사용되는 응용 프로그램인, 다양한 종류의 텍스트 편집기가 포함되어 있습니다. 평문 파일은 시스템 로그와 설정 파일과 같이 어떠한 글꼴 형식이나 스타일 포맷팅이 적용되지 않은 텍스트를 포함한 파일들을 말합니다.

gedit은 그래픽 텍스트 편집기 입니다. 이 프로그램은 평문 파일을 열고, 수정하고 저장하는데 사용됩니다. 또한 다른 그래픽 데스크탑 응용 프로그램에서 텍스트를 가져오거나 다른 프로그램으로 텍스트를 잘라 붙이기 가능합니다. gedit은 간단하고 알아보기 쉬운 인터페이스를 갖추고 있으며, 여러 개의 gedit 창을 열지 않고서도 동시에 한 개 이상의 파일을 열어 볼 수 있는 탭 기능을 사용합니다.

gedit을 시작하시려면, 주 메뉴 => 액세서리 => 텍스트 편집기를 선택하시면 됩니다. 쉘 프롬프트에서 gedit이라고 입력하여 gedit 프로그램을 시작하실 수도 있습니다.

참고알림
 

gedit은 그래픽 데스크탑 환경에서만 사용됩니다.

그림 9-8. gedit

일단 gedit이 시작되면, 공백 편집 공간이 나타날 것입니다. 바로 gedit 사용을 시작하시거나 열기 버튼을 클릭하여 편집하려는 평문 파일을 열 수 있습니다. 열려진 파일은 그림 9-8에서 보이는 것처럼 주 편집 창에 나타납니다. 창 오른쪽에 위치한 스크롤바를 클릭한 후 잡아 끌거나 마우스 커서를 위 아래로 움직여서, 텍스트 파일을 살펴보실 수 있습니다; 또는 텍스트 파일 한 줄씩 이동하시려면 방향키를 사용하시면 됩니다. [Page Up] 키와 [Page Down] 키를 누르시면 문서를 페이지 단위로 보실 수 있습니다.

작은보힌트
 

gedit은 각 파일마다 탭을 사용하여 한 개의 창에서 여러 개의 파일을 열 수 있습니다. 다른 파일에서 이미 열려진 파일로 텍스트를 복사하시려면, 열기 버튼을 클릭하신 후 원하시는 파일을 선택하십시오. 선택하신 파일이 gedit 창의 새 탭에 열릴 것입니다. 각 파일 이름이 적혀진 탭을 클릭하여 각 파일을 열어보실 수 있습니다.

텍스트 파일 편집이나 작성을 마치신 후에는, 도구바에서 저장 버튼을 클릭하시거나 파일 메뉴에서 파일 => 저장을 선택하여 그 파일을 저장하실 수 있습니다. 새로운 텍스트 파일을 작성하시는 경우, 팝업 창이 나타나서 저장할 파일 이름과 디렉토리 명을 요청할 것입니다. 기존 파일을 편집하시는 경우, 다음에 파일을 여시면 변경 사항이 파일에 자동으로 나타납니다. 기존 파일을 다른 이름이나 다른 위치에 저장하시려면, 파일 => 다른 이름으로 저장...을 선택하시면 됩니다. 만일 설정 파일을 수정하시는 경우, 원래 설정 파일을 버리지 않고서 변경 사항을 텍스트하시려면, 파일을 다른 이름이나 다른 위치로 저장하시는 것이 좋습니다.

gedit에 대한 보다 많은 정보를 원하신다면, 파일 메뉴에서 도움말 => 내용을 선택하여 gedit 메뉴얼을 참조하시기 바랍니다.

9.2.1. 쉘 프롬프트 텍스트 편집기

그래픽 데스크탑을 사용하지 않고서 텍스트 파일이나 설정 파일을 읽거나 수정하시려면, Red Hat Linux에 포함된 vi (발음 vee-eye) 텍스트 편집기를 사용하시면 됩니다. vi는 쉘 프롬프트에서 열어 텍스트 파일을 보고, 검색하며 수정하는데 사용되는 단순한 응용 프로그램 입니다. vi를 시작하시려면, 쉘 프롬프트에서 vi라고 입력하시면 됩니다. vi를 사용하여 파일을 여시려면, 쉘 프롬프트에서 vi <파일명> 을 입력하십시오.

그림 9-9. vi

디폴트 값으로 vi는 파일을 일반 모드에서 엽니다. 즉 여러분은 파일을 열고 파일에 명령을 실행하는 것은 가능하지만 파일에 텍스트를 추가하지는 못합니다. 텍스트를 추가하시려면, [i] 키 (끼워넣기 모드)를 누르시면 됩니다. 끼워넣기 모드에서 빠져나오려면, [Esc] 키를 누르시면 vi가 일반 모드로 되돌아 갑니다.

vi를 종료하시려면, [:] 키 (vi 명령 모드)를 입력하시고 [q] 키를 누르신 후 [Enter] 키를 치시면 됩니다. 저장할 텍스트 파일에 변경 사항이 있다면, [:] 키를 누른 후 [w]와 [q] 키를 눌러 변경 사항을 저장한 후 종료하실 수 있습니다. 실수로 파일을 변경하신 경우에는 변경 사항을 저장하지 않고 vi에서 빠져나가기 위해, [:] 키를 입력하신 후 저장하지 않고 강제 종료를 의미하는 [q]와 [!]키를 입력하시면 됩니다.

쉘 프롬프트에서 man vi 명령을 입력하여 vi 사용법에 대한 보다 많은 정보를 보실 수 있습니다.